Mustang Evolution

Mustang Evolution (http://www.mustangevolution.com/forum/)
-   2011-2014 Mustang GT (http://www.mustangevolution.com/forum/f358/)
-   -   Installed Sr lowering springs (http://www.mustangevolution.com/forum/f358/t365258/)

jrdnsky59 02-27-2015 07:36 PM

Installed Sr lowering springs
 
I installed these earlier. The rears I installed with the more compressed coils facing up. Was that the right way? I'm getting a lot of creaking from the back.

Sent from my SM-N910T using Mustang Evolution mobile app

jrdnsky59 02-27-2015 07:38 PM

1 Attachment(s)
I'll snap more pics tomorrow so far pleased with the results.

Sent from my SM-N910T using Mustang Evolution mobile app

Sloasslx 02-27-2015 08:09 PM

Looks good man


Sent from my iPhone using Mustang Evolution

2014oxstang 02-27-2015 08:14 PM

1 Attachment(s)
Looks great. Sweet heat extractors ;) Attachment 176311



Sent from my iPhone using Mustang Evolution

Sloasslx 02-27-2015 08:23 PM

I wish I would have done the Oxford white. Who knows maybe plastidip it.


Sent from my iPhone using Mustang Evolution

2014oxstang 02-27-2015 08:29 PM

Quote:

Originally Posted by Sloasslx (Post 2182269)
I wish I would have done the Oxford white. Who knows maybe plastidip it.


Sent from my iPhone using Mustang Evolution


I love the OW. In a perfect world I'd get the car painted that matte grey/blue on VG's RTR spec 5 or whatever. That color is sick.


Sent from my iPhone using Mustang Evolution

dinobike19 02-27-2015 08:59 PM

Quote:

Originally Posted by jrdnsky59 (Post 2182223)
I'll snap more pics tomorrow so far pleased with the results.

Sent from my SM-N910T using Mustang Evolution mobile app

Looks good. I'll be starting mine tomorrow morning. Hey did you do it the way the video I sent you ? how did it work, any issues?

jrdnsky59 02-27-2015 10:32 PM

Yes I did it worked out great. The whole install took 2 hours.

Sent from my SM-N910T using Mustang Evolution mobile app

---------- Post added at 05:31 AM ---------- Previous post was at 05:31 AM ----------

When taking the strut bolts off make sure to hold the disc firmly. That sob flung my brother back lol.

Sent from my SM-N910T using Mustang Evolution mobile app

---------- Post added at 05:32 AM ---------- Previous post was at 05:31 AM ----------

The only thing is I'm getting a creak from the back.

Sent from my SM-N910T using Mustang Evolution mobile app

dinobike19 02-27-2015 10:33 PM

Good thing he didn't get hurt.


Sent from my iPhone using Mustang Evolution

jrdnsky59 02-27-2015 10:40 PM

1 Attachment(s)
Overall it looks nice. You feel the road a lot more.

Sent from my SM-N910T using Mustang Evolution mobile app

dinobike19 02-27-2015 10:41 PM

Good to hear that's what I'm looking for. Sadly I won't be able to test mine for a month or so


Sent from my iPhone using Mustang Evolution

jrdnsky59 02-27-2015 10:42 PM

Are the rear springs installed with the more compressed coils on top or bottom. The way I installed them the numbers on the springs are upside down

Sent from my SM-N910T using Mustang Evolution mobile app

dinobike19 02-27-2015 10:42 PM

Sounds like the wrong way then


Sent from my iPhone using Mustang Evolution

jrdnsky59 02-27-2015 10:46 PM

I've been trying to search and have found nothing. Can anyone verify which way they go?

Sent from my SM-N910T using Mustang Evolution mobile app

dinobike19 02-27-2015 10:53 PM

Larger spaces of the spring on top. Where the spring is compressed more on the bottom. I'm 99% sure of that


Sent from my iPhone using Mustang Evolution

jrdnsky59 02-27-2015 10:57 PM

http://youtu.be/WUZODaXmkYU

Sent from my SM-N910T using Mustang Evolution mobile app

---------- Post added at 05:57 AM ---------- Previous post was at 05:57 AM ----------

This guy did them the other way around?does it vary by brand of springs you go with?

Sent from my SM-N910T using Mustang Evolution mobile app

dinobike19 02-27-2015 11:01 PM

Looks like I'm wrong. U'll have to take it for a drive and then tomorrow check to see if u have wear marks to find ur problem


Sent from my iPhone using Mustang Evolution

jrdnsky59 02-27-2015 11:14 PM

This guy did the tighter coils on bottom????


http://www.mustangevolution.com/foru...d.php?t=330879

Sent from my SM-N910T using Mustang Evolution mobile app

dinobike19 02-27-2015 11:16 PM

Lol. No real straight answer I see.


Sent from my iPhone using Mustang Evolution

jrdnsky59 02-27-2015 11:18 PM

Hopefully someone can chime in.

Sent from my SM-N910T using Mustang Evolution mobile app

Strange Mud 02-28-2015 10:26 AM

idk but I doubt it matters as long as both diameters are the same.

jrdnsky59 02-28-2015 10:29 AM

I have a feeling I put them on wrong. All these people with Sr springs and no one to chime in.

Sent from my SM-N910T using Mustang Evolution mobile app

Strange Mud 02-28-2015 10:30 AM

pm the guys from AM

jrdnsky59 02-28-2015 10:32 AM

I sent Will a pm

Sent from my SM-N910T using Mustang Evolution mobile app

2014oxstang 02-28-2015 01:02 PM

Maybe you didn't seat the spring on the axle housing pad the right way, or you didn't line up the spring properly. It's hard to say bro. Gotta get back in there and check it out. Having it upside shouldn't cause clunking. Also, did you trim the bump stops? You're probably bottoming out on them.


Sent from my iPhone using Mustang Evolution

olerodder 02-28-2015 02:23 PM

I assume you put the isolators back on the spring that you took off the old ones, right?
Also, although I've only used Eibach's, I thought the upper pocket was smaller than the lower pocket, and I always put them end with the letters/numbers facing towards the rear of the car and so you could read them right side up.
When you took the old ones out did you match them up with the new ones..........both springs should have looked to be in the same orientation although your lowering springs were shorter.
As for the clunking, did you torque everything to factory specs?

jrdnsky59 02-28-2015 03:36 PM

I left the bump stops alone. I tightened everything with an impact gun. The Sr springs had clear isolators in the middle. And am inside of weather they are upside down or not.

Sent from my SM-N910T using Mustang Evolution mobile app

2014oxstang 02-28-2015 03:42 PM

Quote:

Originally Posted by jrdnsky59 (Post 2182628)
I left the bump stops alone. I tightened everything with an impact gun. The Sr springs had clear isolators in the middle. And am inside of weather they are upside down or not.

Sent from my SM-N910T using Mustang Evolution mobile app


Could be the bump stops.


Sent from my iPhone using Mustang Evolution

jrdnsky59 02-28-2015 03:46 PM

I'm gonna drop it and cut the bump stops. and I'm gonna flip the springs. (Tighter coils on bottom)

Sent from my SM-N910T using Mustang Evolution mobile app

jrdnsky59 02-28-2015 03:50 PM

1 Attachment(s)
This is how rears look

Sent from my SM-N910T using Mustang Evolution mobile app

olerodder 02-28-2015 03:59 PM

Quote:

Originally Posted by jrdnsky59 (Post 2182628)
I left the bump stops alone. I tightened everything with an impact gun. The Sr springs had clear isolators in the middle. And am inside of weather they are upside down or not.

Sent from my SM-N910T using Mustang Evolution mobile app

Ok, you need to cut the bump stops in half, this could be causing an issue....maybe.
An impact gun is not a torque wrench. On suspension parts you really should use torque settings.
I'm talking about the rubber insulators that were on the top of the spring and fit between the body and spring.....it's kind of important to get those back where they belong or you will get creaking and groaning with metal to metal.
I think you've got the springs in the right way. Don't the tops have a smaller diameter than the bottoms..........

jrdnsky59 02-28-2015 04:00 PM

No there the same top and bottom. OK I'm gonna drop the rear end and inspect it. I will cut the bumpstops

Sent from my SM-N910T using Mustang Evolution mobile app

olerodder 02-28-2015 04:06 PM

Quote:

Originally Posted by jrdnsky59 (Post 2182638)
No there the same top and bottom. OK I'm gonna drop the rear end and inspect it. I will cut the bumpstops

Sent from my SM-N910T using Mustang Evolution mobile app

Look up in the upper spring pocket and make sure the insulators are between the spring and body. I assume you will check the ends of the spring to make sure they are seated in the pocket also.

jrdnsky59 02-28-2015 04:07 PM

For the rears?

Sent from my SM-N910T using Mustang Evolution mobile app

2014oxstang 02-28-2015 04:11 PM

Quote:

Originally Posted by olerodder (Post 2182636)
Ok, you need to cut the bump stops in half, this could be causing an issue....maybe.
An impact gun is not a torque wrench. On suspension parts you really should use torque settings.
I'm talking about the rubber insulators that were on the top of the spring and fit between the body and spring.....it's kind of important to get those back where they belong or you will get creaking and groaning with metal to metal.
I think you've got the springs in the right way. Don't the tops have a smaller diameter than the bottoms..........


This ^

The bump stops need to be cut in half. And torque everything to spec, not guess with a gun. There's a good chance everything is over torqued.


Sent from my iPhone using Mustang Evolution


02:54 AM

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.