Code P0442 V6 - Mustang Evolution

Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 05-13-2018, 11:05 AM   #1
Registered User
Newbie
 
Redesiuk's Avatar
 
Join Date: May 2018
Location: New Jersey
Posts: 13
Code P0442 V6

Alright, I ended up getting the check service light coming on just before inspection (of course right?), and as far as I can tell so far, I don't think it's the gas cap, as I replaced it, and drove it a bit, so I'm not sure what else it may be.



Is there anyone here, who for a definite had a certain issue I should tackle first, I was going to go cheapest to most expensive, since sometimes the dumbest thing would cause the small emission leak. I looked that up it said something with the charcoal canister hoses. I'm not sure if it truly is that. It's a 2003 v6. Any suggestions?
__________________
" For with much wisdom comes much sorrow ; the more knowledge the more grief. "
Redesiuk is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-13-2018, 05:49 PM   #2
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: North Carolina
Region: Other
Posts: 1,813
Could be any one of these things. Start with the simplest/cheapest.

A loose or improperly affixed gas cap
A non-conforming gas cap (i.e. not factory/original brand)
A small leak/hole in a fuel vapor hose/tube
Other small leak in EVAP system
Faulty vent o-ring seal
Defective vent valve
Defective purge valve
Defective leak detection pump
__________________
03 GT Convertible

07 V6 Coupe
17 Charger SRT
jkeaton is offline   Reply With Quote
Old 05-13-2018, 09:15 PM   #3
Registered User
Newbie
 
Redesiuk's Avatar
 
Join Date: May 2018
Location: New Jersey
Posts: 13
Yeah, I replaced the gas cap already with an actual locking one I bought since the old one looked gunked up. Figured I'd just buy a new one. Some say replace the grommet as that could do it too. Didn't turn it off even after I drove it for a bit though with the new cap, so I'll have to move onto the next thing. My other car, the focus, when it wasn't on all the way would turn the gas cap light on then eventually check engine. But, different cars all together.
__________________
" For with much wisdom comes much sorrow ; the more knowledge the more grief. "
Redesiuk is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-14-2018, 05:58 AM   #4
Registered Member
Regular
 
jkeaton's Avatar
 
Join Date: Jun 2016
Location: North Carolina
Region: Other
Posts: 1,813
Is the new gas cap an actual OEM (dealer bought) cap? It may sound weird, but sometimes only an OEM cap will work.
__________________
03 GT Convertible

07 V6 Coupe
17 Charger SRT
jkeaton is offline   Reply With Quote
Old 06-09-2018, 12:39 AM   #5
Registered User
Newbie
 
Venum615Fighter's Avatar
 
Join Date: Jun 2018
Posts: 2
I'm having the same issue. I realized I'm leaking air on the passenger side egr tube where it meets the header. If I were you I'd get your car smoke tested.

I don't have emissions where I live so I'm deleting the whole egr system.
Venum615Fighter is offline   Reply With Quote
Old 06-17-2018, 11:21 AM   #6
Registered User
Newbie
 
Redesiuk's Avatar
 
Join Date: May 2018
Location: New Jersey
Posts: 13
Yeah, I suppose I'll have to do that, or maybe just replace that part since you mentioned it. Problem is my first manual, so getting it to a shop is annoying, I don't have much time between work to try it out, so I also can't full get it there.
__________________
" For with much wisdom comes much sorrow ; the more knowledge the more grief. "
Redesiuk is offline   Reply With Quote
Old 06-17-2018, 07:46 PM   #7
Registered User
Newbie
 
Venum615Fighter's Avatar
 
Join Date: Jun 2018
Posts: 2
I deleted the egr system and the car runs like when I first bought it if not better. There's no hesitation, studder, or struggle on load. The rpm's are steady.

Here's the write up I used to delete the system:
http://www.moddedmustangs.com/forums.../topics/219948

I didn't do everything word for word but so far so good.
Venum615Fighter is offline   Reply With Quote
Old 06-19-2018, 10:38 AM   #8
Registered Member

Regular
 
Join Date: Jun 2015
Location: Spokane
Region: Washington
Posts: 1,951
Sometimes, it is not the miles driven with a code fix in place, but the number of on/off cycles (typically five or more) for the engine......have you tried turning the code off to see if it comes back on?
Autozone has code readers, and will plug into your car for no fee, and I think they can turn off the code as well.....
Guard 5.0 is offline   Reply With Quote
Old 06-19-2018, 11:46 AM   #9
Registered Member
Regular
 
Join Date: Oct 2017
Location: Millersville, MD
Region: Maryland
Posts: 74
Man, P0442 is a PITA code.

I had already replaced the charcoal canister and purge valve, yet the code kept coming back. I smoke tested it and couldn't find the issue. Honestly, the smoke testing was harder than I thought.

Long story short, CHECK YOUR HOSES man. I had to go back to my mechanic and they swapped out the charcoal canister again, but the CEL came back in 2 days.
You know what it ended up being, or at least was also part of the problem?
Old hoses. Looked ok, but they were dry and cracking from the inside out. $2 fix from bulk vacuum hose.
Conspiracy is offline   Reply With Quote
Old 07-20-2018, 11:33 AM   #10
Registered User
Newbie
 
Redesiuk's Avatar
 
Join Date: May 2018
Location: New Jersey
Posts: 13
I have actually cleared it, so far it hasn't come on, but I didn't drive that far, so maybe it was just the gas cap, I'm uncertain, but I plan on replacing hoses, and moldings, etc because it's all gonna dry rot eventually. I'm waiting to see then go down the list from smaller to bigger, like the hoses to replace.
__________________
" For with much wisdom comes much sorrow ; the more knowledge the more grief. "
Redesiuk is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > 4 Cylinder | V6 | Classic Mustangs || Tech and Talk > Pre-2005 V6 Mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Codes P1233 and P0442 after fuel filter change John_04_Zonker Pre-2005 V6 Mustang 3 10-14-2015 08:34 PM
Error code P0442 Kstangs2002 2011-2014 Mustang GT 4 03-22-2015 06:38 PM
CEL p0442 bsyo1021 2011-2014 Mustang GT 3 06-21-2014 12:42 AM
CEL and code P0442 TwoSeveN 2005-2010 V6 Mustang 6 08-16-2011 08:15 PM
P0442 and P0456PD CEL OsirisGuy 1996-2004 Mustang GT 4 09-01-2009 11:57 AM

» Premium Vendor
» Like Us On Facebook



10:47 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.