2010 Mustang GT Radio Console not illuminating - Mustang Evolution

Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert



Reply
 
Thread Tools Search this Thread
Please support our sponsors and let them know you heard about them here!
Old 07-07-2019, 12:16 PM   #1
Registered Member
Regular
 
Mgalli's Avatar
 
Join Date: Dec 2013
Location: McKinney
Region: Texas
Posts: 56
2010 Mustang GT Radio Console not illuminating

Hoping someone can help. My 2010 Mustang GT radio screen no longer illuminates. I checked all the little plastic fuses in the passenger side fuse box and all look good.

Any other suggestions how I can get the radio to illuminate again?

Thanks very much in advance
__________________

2010 GT Premium

Eibach ProSystem Plus, Airaid CAI, BBK Catted X Pipe, Flowmaster Outlaw Axlebacks, 20" Staggered Black DF5 Wheels (275/35/20 & 255/35/20), BAMA 93 Race Tune, Power Stop Z23 Evolution Sport Brake Rotor & Pad Kit, American Muscle Graphic Smoked Light Tint, SR Performance Strut Tower Brace, Raxiom Map LEDs
Mgalli is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-03-2019, 02:38 PM   #2
Registered Member
Regular
 
wbrockstar's Avatar
 
Join Date: Mar 2015
Location: Nashville
Region: Tennessee
Posts: 298
I don't own a newer model like yours,but from researching info about the newer models,the following things were listed that you can try to solve your issue.It was stated,that anytime you leave an electrical item plugged in to your power outlet (for charging) for an extended amount of time (with the vehicle turned off) it will trigger a drain on the battery and once it reaches a set point,it will trigger the radio to shut completely off (similar to tripping a breaker) Even a usb cable,thats not plugged into anything,will cause it to drain.Owners mentioned anywhere from a few hours to a few days of an item or a usb itself being plugged into the power outlet,with the vehicle off,could cause this.The first thing to try is making sure fuse #3 & #39 are good.Next,disconnect the neg battery cable for 10-15 minutes then reconnect it.If the radio doesn't come on once you reconnect the battery and start the vehicle,the battery may require that you drive the vehicle at highway speeds for 60-120 minutes before it will have time to charge enough to reset the radio.If this doesn't work,put the battery on a trickle charger until fully charged then drive it for 60-120 minutes. Apparently,once the battery reaches a full charge again,the radio should start working again.I guess once the battery drains to a specific value,anything not crucial to engine startup is shutdown so that the starter,pcm,etc will have enough battery reserve to allow the engine to start and run.
__________________
91 LX 342ci(10.5:1)
TFS 190cc(stage ll)
TFS track heat
XE276HR .544" .544"
Flowtech 1 3/4"
Prochamber w FM
wbrockstar is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Mustang Evolution > Mustang Evolution | Community Forums > Mustang 101 - Tech Basics | Ask an Expert

Tags
2010 mustang

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


» Premium Vendor
» Like Us On Facebook



01:03 PM


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

MustangEvolution.com is in no way associated with or endorsed by Ford Motor Company.