Mustang Evolution Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
869 Posts
Discussion Starter #1
I got a winding sounding from my engine guessing its a pully. An 02 4.6L GT but only weird thing is I can barely push the clutch in an sound goes away. Is that normal for the pullys? And is it a SOB to replace them thanks
 

·
Registered
Joined
·
1,013 Posts
if u push the clutch in a tad and it goes away, im pretty sure that would be the tob, throw out bearing which needs replacing soon. pulley whine would be continuous even pressing or depressing the clutch since its constantly under tension from the belts
 

·
Registered
Joined
·
50 Posts
That's your tob mine does the same it's common on 94-98 there's a spring that needs wearing in I've had it tested since my clutch only has 20,000 on it and mine makes that noise too
 

·
Registered
Joined
·
869 Posts
Discussion Starter #4
M97stang said:
That's your tob mine does the same it's common on 94-98 there's a spring that needs wearing in I've had it tested since my clutch only has 20,000 on it and mine makes that noise too
A spring I replaced clutch TOB and pressure plate not even 2000 miles ago
 

·
Registered
Joined
·
50 Posts
I was told at amp performance one of two top mustang shops that 84-98 have thst problems there's a spring thst gives tension and wen new its not makeing full contact or something like that and once it wares in a but it have tension on bit and won't have that noise any more call around ask questions
 

·
Registered
Joined
·
869 Posts
Discussion Starter #6
M97stang said:
I was told at amp performance one of two top mustang shops that 84-98 have thst problems there's a spring thst gives tension and wen new its not makeing full contact or something like that and once it wares in a but it have tension on bit and won't have that noise any more call around ask questions
I have an 02 so I guess it's not that Ima go around and ask
 
1 - 6 of 6 Posts
Top