Mustang Evolution Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
203 Posts
Discussion Starter #1
I just put steeda cat deletes on and updated my bama tune with it. Its the new V2 tune and it is really smooth, idles great, and has plenty of power, but I reset my mpg to see what the difference would be and its been at 10.1 for about 2 days of driving now. I dont see how the deletes could make it worse, if anything i feel like it would help it.
I am thinking it must be the tune. Any help would be appreciated.
 

·
Sad Panda
Joined
·
5,640 Posts
If I were you I'd drive it till its empty, fill it up then check the actual mpg


Sent from my iPad using Mustang Evolution
 

·
Registered
Joined
·
3,726 Posts
Sounds like COT is still on. It needs to be turned off in the tune.
 

·
Registered
Joined
·
81 Posts
I just put steeda cat deletes on and updated my bama tune with it. Its the new V2 tune and it is really smooth, idles great, and has plenty of power, but I reset my mpg to see what the difference would be and its been at 10.1 for about 2 days of driving now. I dont see how the deletes could make it worse, if anything i feel like it would help it.
I am thinking it must be the tune. Any help would be appreciated.
Try setting your cluster to metric, then back to imperial. 10.1 litres per 100 km, is what I'm used to seeing.
 

·
Registered
Joined
·
1,015 Posts
Try not stomping the gas pedal at every red light? :cool:

If I hit reset and drive it like I stole it.... "testing out" my new performance mods.... I get about <10 mpg too. Then again... my best city mpg is only about 14.x mpg.

I rarely do highway miles, so don't really get much of the high mpg's averaged in there.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #7
Well i have been trying to keep it easy just to test it. My instant mpg goes down to 10 when i lightly touch the gas. Only ever goes up to 15 or 16 when im barely touching it. Its pretty 0 if i ha e ti accelerate at all.

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
 

·
Registered
Joined
·
2,171 Posts
I just put steeda cat deletes on and updated my bama tune with it. Its the new V2 tune and it is really smooth, idles great, and has plenty of power, but I reset my mpg to see what the difference would be and its been at 10.1 for about 2 days of driving now. I dont see how the deletes could make it worse, if anything i feel like it would help it.
I am thinking it must be the tune. Any help would be appreciated.
Hey fax,

Keep an eye on it! When you freshly tune the car and reset the MPG it's going to take a while for it to learn the driving habits all over again and average out. Especially after changing all the parameters that the tune does.

I would recommend giving it some time and seeing what happens, if the MPG stays down, should the Bama team a call and I guarantee that they can adjust that for you.

Hope this helps!

-Will
 

·
Registered
Joined
·
203 Posts
Discussion Starter #9
Thats what i think im going to do. It just psyvhs me out seeing it that low haha. Ill let you guys know what happens in the next few days. Im driving up to the lake tomorrow and then back. Mostly highway. Ill see if it improves after that

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
 

·
Registered
Joined
·
2,093 Posts
Every time I have to re-flash my PCM due to tune revision or whatever, I always put at least 50~ grandma miles on it before getting on it or even going WOT (since I have an auto, shift points take a while to smooth out). The PCM also has to relearn idle and all of the rest of the parameters.

If you're unsure, you can always use your tuner to erase the on-board memory and "start over." Just crank it, let it get to operating temp, put A/C on for few mins, then put a few easy miles on it to ensure everything is running right.
 

·
Registered
Joined
·
2,112 Posts
Did you happen to follow up on Grabber Blue5.0's comment above regarding the COT setting in the tune?
COT(Cat Over Temperature) It is a system in the car that dumps raw fuel in the exhaust to cool down the cats.
Apparently when the cats have been removed the COT should be disabled.

Or did you check it out with Bama?
 

·
Registered
Joined
·
203 Posts
Discussion Starter #13
No i havent checked that out yet. I assume bama would know to take care of that, but is there a way to turn it off from the tuner

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
 

·
Registered
Joined
·
2,093 Posts
No i havent checked that out yet. I assume bama would know to take care of that, but is there a way to turn it off from the tuner

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
I'd highly recommend that you let Bama attempt to address your issue first. There may be more than one parameter that needs to be addressed and if you mess with only one, it could snowball into other parameters and become a disaster.

Just my $0.02.
 

·
Admin
Joined
·
5,822 Posts
Did you change your rear gearing? If so, your tune may not have the correct gear ratio set.
 

·
Premium Member
Joined
·
3,535 Posts
Even at 10.1, you are 2.1 better than me lololol.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #17
I have driven it on the highway some now and its up to 14, so maybe it is just taking some time. Ill let you guys know after a few more days if i can get it back up to 16 lol.

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
 

·
Registered
Joined
·
203 Posts
Discussion Starter #18
Just got it running back where it should be. Still some low spots, but i was getting close to 40mpg over 5 minute intervals at 60mph. Thats unheard of. I guess i was being a bit paranoid lol

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
 

Attachments

1 - 18 of 18 Posts
Top