Mustang Evolution Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
For some reason my #18 fuse keeps blowing. None of my dash gages work with exception for the odometer. As soon as I replace the fuse with the required 15 amp fuse it blows the minute I turn the igniton. I decided to place a higher amp fuse just to see what the thresh hold was and I got to a 30 amp without it blowing when I turned the ignition. However, the second i push on the gas it blows.

Acording to my chilton book #18 circuit controls the Warning Indicator Lamps, Throttle Solenoid Positioner, Low Fuel Module, Dual Timer Buzzer, Tachometer, Engine Idle Track Relay, and Fluids Module Display

Any common faults I need to look at? Any ideas would help. Thanks
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I've checked the ground behind the intake manifold and the one off the starter solenoid and both were nice and tight, free of corosion. I am not a mechanic by any means. I'm trying to learn as I go as I really want to know how to repair my car when needed. So sorry if I seem ignorant.
 

·
Registered
Joined
·
200 Posts
I think what foxtrot was getting at was grounds under the dash like you would see for the radio, cig lighter ect. I would start looking for stray wires under the dash that might be spliced, frayed or cut as well.
 

·
Moderator Emeritus
Joined
·
4,786 Posts
Do you have an aftermarket stero? Maybe the constant is tied to one of those circuits and is grounding out..
 

·
Registered
Joined
·
135 Posts
Yea if you put in an after market stereo you might hooked something up wrong , forgot a cable or a ground could have came loose that would be the first place I check then from the fuse box to various connection points ...check the simple stuff first but it sounds like there is a short in a wire somewhere if you messed with any of the wires installing something I'd check there first and double check your work.I messed up my stereo install kept blowing a fuse and my dash and ac lights would go out it was a full day of figuring out what was wrong taking off my dash and what not it ended up being my wiring mistake took couple min to fix. Well lesson learned :/ I'm new to most of this too
 
1 - 6 of 6 Posts
Top