Mustang Evolution Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I started with a fuel pump issue not getting power to the pump so I replace the relay,wiring and fuel pump and still not getting any power to the fuel pump from the relay back without crossing out over, I have bypassed the inertia switch just in case it was an issue and I got nothing, now the ignition won't crank most of the time and when it does it tends to stick even with the key off, I'm hoping it is the starter switch or the module but frankly I'm frustrated.any suggestions or ideas what the problem is???
 

·
Banned
Joined
·
8,044 Posts
Hmm.. if your starter switch is sticking I would start there. Get yourself a service manual and use the schematics to figure out what wires should have power with the key on and key off and start checking. Sorry I.don't have a better answer but only a multimeter will be able to trouble shoot this. Good luck.
 

·
Registered
Joined
·
155 Posts
Thought I had pump trouble on my bird once and it was the key. Dang thing lost its programming. Doubt its your key though. They didn't put chip keys out back then. On my 93 stang, thought it was pump , but it was the crank sensor. Same symptoms as pump...
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Yeah but it would still fire if I was the sensor I'm not getting any power to my distributor either so I think its in my ignition because that would kill my fuel pump too
 
1 - 5 of 5 Posts
Top