Mustang Evolution Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Helllo all, I just bought a 1996 fixer upper for my daughter. Trying to go through it and list all the known issues for repair.

Main electrical issues:

RESOLVED 1. When turning key, opposite of starting, of which I'd usually call it accessory only mode, nothing powers up at all. Update: Cleaned bulkhead conections at the drivers kickpanel, and of course it could have been that missing fuse as well.

RESOLVED 2. ODBII port apparently is not powering up my tester, as it says it must be powered by the vehicle. Therefore it's only running on it's internal battery in order to display the error mentioned. Update: Radio fuse was completely missing, checked all existing fuses, never dreamed a fuse would be missing.

RESOLVED 3. Radio does not work, no power. Update: Radio fuse was completely missing, checked all existing fuses, never dreamed a fuse would be missing.

RESOLVED 4. Front seat will not move in any direction, I assume no power as well. Note: The very first time I tried to move the seat, it moved for a couple of seconds and then nothing. Prior to that short movement, all of the other electrical issues were already noted as being an issue. Update: Found fusebox under the hood, fuse for seats blown.

5. Driver's window will not operate, no noise, assuming no power, yet the passenger unit is fine.

6. Electronic doorlock's do not work. Now when I press the locking button, I hear a motor in the drivers door run, but no lock movement.

RESOLVED 7. Electronic mirror adjustments do not work, either side. Update: Could have been the bulkhead connector cleaning or the missing fuse.

8. Voltmeter in instrument panel does not work.

Thanks in advance for any help one might be able to throw at me.
 

·
Registered
Joined
·
2,252 Posts
Hmm. To start simple check every single power hook up to see if its plugged in and not corroded to the point of not working.

Number 1 could maybe be the chip bad in your key? My friends chip came loose in his and it wouldn't turn, some will turn but nothin happens.. Some turn the motor over but never actually cranks up..
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3 (Edited)
Resolved #5: Window operation - Electrical connector inside the door to the window motor disconnected.

Reslolved #6: Door Locking issue, had to replace electric lock actuators.

Resolved #8: Voltmeter and Oil Gauge were fixed by removing the instrument cluster, and cleaning the copper flex circuitboard with WD40.
 
1 - 3 of 3 Posts
Top