Mustang Evolution Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
my check engine light is on and has been on for a while. but lately my car has been almost chocking i guess. it runs good while im just cruising but when i give it gas it starts acting up. but then on the way to work the check engine light starting flashing about 9 or 10 times then went off. then on the way home it starting flashing again the same amount of times and stayed on. it scared me cause idk what it means. i cant get a code read til in the morning. any suggestions would b extremely appreciated.
 

·
Premium Member
Joined
·
1,499 Posts
Sounds like you need to clean your maf , or a fuel delivery problem
 

·
Premium Member
Joined
·
1,499 Posts
Yea not a problem my light comes on every time I give it gas lol I did my fuel filter and fuel pump never cleaned my maf because I did my cai and it looked pretty clean could be because I have no cats but Iam pretty sure my year didn't come with rear o2 censors correct me if I am wrong so I have no idea what is wrong with it
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Yea I already changed one of my O2 sensors. Thankfully all 4 of mine r the same. But I'll def try that and c where I stand. I work at oreilly auto parts so I can get just about n e thing I need.
 

·
Registered
Joined
·
1,013 Posts
Posts the codes on hear to have an idea....could be cylinder missfire due to coolant leak from intake manifold or something o2 can do it too popping a lack of flow for 02s
 

·
Registered
Joined
·
540 Posts
You might be getting misfire codes but I had the same thing wrong with my 2000 gt. turns out the fuel pump was going out. It would pump ok for idle and cruise but open her up and she would starve. New svt focus pump later and I even get better gas mileage.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Thanks. But I still don't know what the p1131 is. It just says running lean. But I replaced the o2 sensor and it still is on. Idk what else to do. Could it b the pcv hose? Its kinda dry rotted and I can only go thru ford for it. I'm gonna get it prolly this week but I don't c it throwing that code. Idk. I'm stumped on it.
 

·
Registered
Joined
·
1,013 Posts
P1131 = Insufficient Switching O2 Bank 1 Sensor 1 Sensor/Lean

In other works might mean since u have a misfire on cyl 5 i would check injector on that cylinder, or see if its wet from intake or oiled up on the spark plugs. cylinder 5 misfiring will set off the o2 sensor for bank 1 since cyl 5 is on bank 1. also, could be a vacuum leak too but i would deff check #5 cyl to see whats causing it to misfire, fixin that will fix the o2 code
 
1 - 11 of 11 Posts
Top