Mustang Evolution Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
What's up everyone. So over the holidays I received a pair of smoked led tail lights from am. I've heard that these tail lights if not set up correctly will cause problems. Well I installed them an they instantly blew my rear light fuses. Anyone have any ideas or experienced the same problems? They didn't come with any directions whatsoever.. Thanks
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #3 ·
No, they came with ends on them or whatever you call it, so you just take the bulbs out and it plug in the the wires from the lights directly
 

·
Premium Member
Joined
·
3,270 Posts
No, they came with ends on them or whatever you call it, so you just take the bulbs out and it plug in the the wires from the lights directly
You have to make sure the plugs are in the correct way. I had the same issue and had to unplug them both and plug them in one at a time.
 

·
Premium Member
Joined
·
3,270 Posts
Did you have to splice any wires? Sounds like you have two wires mixed up
They only plug into the sockets correctly one way... Put them opposite and they blow the fuse, only took me about 15 fuses to figure it out. Lol
 

·
Premium Member
Joined
·
3,270 Posts
What do you mean the "correct way" they seem pretty simple?
I'll take pics for you in a min to show you clearly. Each of the new plugs has only 3 connections instead of 4 like the lights, it has to be on the correct side to not blow the fuse.
 

·
Banned
Joined
·
422 Posts
93fox said:
What do you mean the "correct way" they seem pretty simple?
Think of it like plugging something into a wall in your house. The plug "should" only go in one way. Try unhooking them and plug them in the other way. One light at a time
 

·
Registered
Joined
·
132 Posts
That looks clean I like the stang on the Wing. What do I need to get to get that on mine? those led tail lights brings the back end back to life!! Nice
 
1 - 16 of 16 Posts
Top