Mustang Evolution Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1
I have a 95 GT (many aftermarket items under the hood, problem is they were there when i traded for it so im still narrowing down whats what) i attempted to set the timing, pulled the spout, set it at 10 Deg replaced the spout car wont run. manual timing set by ear at almost 20 deg, car runs hard. recently replaced both O2 sensors now i havce rough idle. I am going to recheck the timing tonight. i have seen all over the net posts on this specific issue but have yet to see an actual answer or post as to why or what it could be. oh after i replaced th o2 sensors my dash warning lights and steroe quit could be coinicidence or as ive found everytime i fix something i find another small issue.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #5
ill look at the 2 books i have i thought one showed how to. if it does ill post tonite.
 

·
Banned
Joined
·
8,044 Posts
first if you dont have a haynes or chilton book it woukd be a good time to get it. you will need it to chase anywires that are associated with the parts that arent working.

when you pulled and inserted the spout did you do it with the car off? also make sure you set it to 10* btdc (before top dead center) it would be the 10 mark to right of the 0*

i would go through all the basic tuneup stuff also.
clean throttle body, maf, and iac,
make sure you plugs, wires, and cap and rotor are in good shape.
if the car hasnt ran in a while use some fuel cleaner/stabalizer.

also you should have 38 lbs of fuel pressure with the vacuum line removed.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #7
ok the spout, the manual i have says to do it with the car running should it be off? as for the rest yes all that is good. I do have a question about the timing marker I just saw a remark in another forum that shows the timing marker with the circular hole and a pointer above ( to the right) it said to time off the pointer not the circle. first id seen of this and im not sure mine has a pointer, ill look in a couple hours when i get home.
 

·
Banned
Joined
·
8,044 Posts
Jar72 said:
ok the spout, the manual i have says to do it with the car running should it be off? as for the rest yes all that is good. I do have a question about the timing marker I just saw a remark in another forum that shows the timing marker with the circular hole and a pointer above ( to the right) it said to time off the pointer not the circle. first id seen of this and im not sure mine has a pointer, ill look in a couple hours when i get home.
yes the car should be off when removing the spout. and yes there should be a pointer.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #9
Well that did it I just didn't see the upper edge hose was in the way. I will say my ear was Damn close. 14 deg. Set at 10 for starters. Will adjust as I go. Thanks for the help. Now I can move on to the drive train.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #11
Alright another quick question. It seems to be weak now when I get on it. What is a good suggestion for timing. I know this for sure. Bbk long headers. Offroad h pipe. Permormance throttle body. Msd coil. cold air Intake.
 

·
Banned
Joined
·
8,044 Posts
up to 12-14. also when going that farits a good idea to use higher octane fuel to prevent pinginig. if there is not pinging at 12 then no reason to. but just becareful and listen for it. but its a great free mod and will wake it up.
 
1 - 12 of 12 Posts
Top