Mustang Evolution Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
aight guys, i put in some new spark plugs and now i get this engine jerk when i give it about half throttle or full. :disgust: Thinking they might be the wrong heat range? :confused: What do you think it is? or should i change the spark plugs again? I was thinking about getting some splitfire plugs. just let me know asap please. The cylinders arent missing or anything its not that bad of a jerk just somewhat of one where i can feel it pretty bad, thanks alot.


Bret
 

·
Premium Member
Joined
·
1,461 Posts
Well what heat range and type of plugs did you get? And did you make sure that the spark plug wire has a good connection with the spark plug? I know sometimes when people take the wires off the plugs, they wiggle them off and cause the prongs inside to spread out too far so that they don't fully connect to the plug. If you lightly pull on wires by each plug you'll be able to feel if it's connected.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
nah its not the wires. That was the first thing i checked.. ill have to look at the heat range and stuff.. any more ideas???
 

·
Premium Member
Joined
·
1,461 Posts
Well what type of plugs did you use? And did you replace one at a time and then put the wire back on or did you pull all the wires and all the plugs at the same time. It does sound like a loose wire or maybe even a you placed the #5 wire on the #4 cylinder. Make sure you routed your wires to the right cylinder. Take a pic if you can too please.
 
1 - 4 of 4 Posts
Top