Mustang Evolution Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
my antifreeze is leaking and it appears to be at the water pump. i have replaced the water pump and still leaking. heater will not work if all the water is damn near gone of course. NO fluid leaking in passenger floorboard - totally dry! What now - gasket??
 

·
Registered
Joined
·
216 Posts
Check the thermostat housing above the water pump. It's a 50 dollar piece of plastic and I have had to replace that before.
 

·
Registered
Joined
·
224 Posts
That's crazy I'm having the exact problem and I noticed that around that $50 dollar piece of plastic there is a chalky white substance so I think I'm gonna replace that and see if that solves the leak.
 

·
Registered
Joined
·
216 Posts
I got mine at oreillys auto parts. Autozone would have had to order it.

---------- Post added at 09:38 AM ---------- Previous post was at 09:38 AM ----------

At the time
 

·
Registered
Joined
·
224 Posts
Thank you so much man Ford wanted $159.00 for the kit and they wouldn't sell me just the housing alone. I'm getting it from oriellys for $46.99
 

·
Registered
Joined
·
216 Posts
Oh and pick up a new o ring for the sensor. I don't recall the size but I had fits trying to get mine to quit leaking. Replacement cost about 50 cents.

---------- Post added at 01:27 PM ---------- Previous post was at 01:25 PM ----------

gc19662007 said:
Oh and pick up a new o ring for the sensor. I don't recall the size but I had fits trying to get mine to quit leaking. Replacement cost about 50 cents.
I'd replace it regardless but I didn't realize at the time there was one in there.
 

·
Registered
Joined
·
200 Posts
The white residue is most likely your leak. Or you could do a pressure test on your cooling system to isolate the leak.
 
1 - 11 of 11 Posts
Top