Mustang Evolution Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
So today while driving on the road I decided it was gonna punch it past this car and when I slowed down to 25 and hit the petal to full the car just revved up, exhaust was really loud And nothing happened, I immediately let off the gas and let the rpms fall. Then I gave it 1/4 gas and she picked up fine, and drove normal the rest of the way home. So is there something wrong? Or what happened?
 

·
Registered
Joined
·
3,463 Posts
moto113 said:
So today while driving on the road I decided it was gonna punch it past this car and when I slowed down to 25 and hit the petal to full the car just revved up, exhaust was really loud And nothing happened, I immediately let off the gas and let the rpms fall. Then I gave it 1/4 gas and she picked up fine, and drove normal the rest of the way home. So is there something wrong? Or what happened?
Mine does this on take of sometimes. Spools up to about 3k then kicks in gear. Can't be good.
 

·
Registered
Joined
·
289 Posts
Yah this happens to me to i think it has to deal with the tune going from cruising speed to punching it
 

·
Registered
Joined
·
3,463 Posts
Twin variable cam timing. Whatever is called it still has to realize how much throttle you give and mustangs are already famous for throttle lag
 

·
Registered
Joined
·
790 Posts
None of this should cause the car to rev to near redline without going anywhere. the lag in the auto is nothing more than the computer deciding what gear to go into but the car doesnt rev as if its in neautral.
 

·
Registered
Joined
·
3,463 Posts
Midnight2012 said:
None of this should cause the car to rev to near redline without going anywhere. the lag in the auto is nothing more than the computer deciding what gear to go into but the car doesnt rev as if its in neautral.
Mine does. To 2.5-3 and then kicks. It's not fast enough.
 

·
Registered
Joined
·
790 Posts
Whitelightning said:
Mine does. To 2.5-3 and then kicks. It's not fast enough.
Gonna have to pay more attention to my tack but I believe it moves forward in the higher gear until it downshifts. The torque converter shouldnt allow it to just rev to 2.5 - 3 as it 's an 1800 or so stall speed from what I understand. Dont we have any Ford techs on here?
 

·
Registered
Joined
·
3,463 Posts
Got a guy named josh on fb in the mustang evolution sixxer group. That's about the only one I know.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #10
Well I don't think the rpms red lined. Honestly I was worried and just starred up. And froze a little. But they dropped fast. So maybe it only went 3500 Rpms. But I'm not positive
 

·
Registered
Joined
·
3,463 Posts
moto113 said:
Well I don't think the rpms red lined. Honestly I was worried and just starred up. And froze a little. But they dropped fast. So maybe it only went 3500 Rpms. But I'm not positive
Does yours drop fast mine? Mine rise fast and kinda slowly wind down
 

·
Registered
Joined
·
1,143 Posts
Im heading to the gf's house right now, ill pull up the service manual for it when i get there. Off the top of my head, (mind you manual vehicles are more my thing) it sounds like the engine and transmission may not be grabbing each other. Though im not sure that's it. Give me a bit and ill pop back in
 

·
Registered
Joined
·
149 Posts
Discussion Starter #14
Thank you!!! I really wanna know if its just the computer doing some safety feature. Or if I should take it in... 7500 miles only on her
 

·
Registered
Joined
·
1,143 Posts
moto113 said:
Thank you!!! I really wanna know if its just the computer doing some safety feature. Or if I should take it in... 7500 miles only on her
alrefire said:
it happened to me only twice.
both times when i was in reverse, and didn't stop completely before switching to drive.
i think it's like a mini rev drop
Cars still under warranty? Sounds like a computer issue, a minor one, but one none the less. Im still looking stuff up, but ill let ya know if i find anything else. While im at it, for those with issues, post your VIN, ill be able to pull more stuff up this way
 

·
Registered
Joined
·
3,463 Posts
alrefire said:
it happened to me only twice.
both times when i was in reverse, and didn't stop completely before switching to drive.
i think it's like a mini rev drop
I stop completely before shifting gears. Mine is from a dead stop to 2nd gear. Weird.
 
1 - 17 of 17 Posts
Top