Mustang Evolution Forum banner

1 - 12 of 12 Posts

·
Banned
Joined
·
610 Posts
Discussion Starter #1
Hey guys i been having this problem eveerytime i park uphill or downhill when i try to move from park to reverse it feels hard like its stuck and i have to mess around with the steering wheel in order to be able to move it out of park. It does move but it still feels hard and kinda makes a pop sound . What could it be
 

·
Registered
Joined
·
411 Posts
Andy714 said:
Hey guys i been having this problem eveerytime i park uphill or downhill when i try to move from park to reverse it feels hard like its stuck and i have to mess around with the steering wheel in order to be able to move it out of park. It does move but it still feels hard and kinda makes a pop sound . What could it be
When you park put your parking break to lay off your parking gear... While you have your parking break on when you start up put it in drive or reverse then take of your parking break and go... This helps your transmission...
 

·
Banned
Joined
·
610 Posts
Discussion Starter #3
Ok so when i stop and ready to put it on park i should put my e brake first and the put it on park?
 

·
Registered
Joined
·
411 Posts
yes hold you foot on the braking pedal... put the ebrake then put it in park... then when you are getting in to drive again .. put your foot on the brake pedal... take it off park... then release the ebrake and you shouldnt feel the hard park break anymore.
 

·
Registered
Joined
·
344 Posts
This is why manual tranny's are bestest!

Glad you found a fix.
 

·
Registered
Joined
·
459 Posts
Sorry to bug in but I have the same issue, and I do as you say hold my foot on the break and apply the ebrake then release the foot break, still feel the car going back a bit and to start the car same procedure but reverse. Apply foot break, release ebrake and while still foot on brake put on gear and it still feels the little break. I try not to park uphill that much. Possible problems with the ebrake.
 

·
Registered
Joined
·
344 Posts
I'll teach you, Andy. Look me up next time you're in western, coastal Canada.
 

·
Banned
Joined
·
610 Posts
Discussion Starter #12
Mkolabin said:
I'll teach you, Andy. Look me up next time you're in western, coastal Canada.
Haha that wouldnt be anytime soon

---------- Post added at 03:13 AM ---------- Previous post was at 03:12 AM ----------

Jayjay said:
Sorry to bug in but I have the same issue, and I do as you say hold my foot on the break and apply the ebrake then release the foot break, still feel the car going back a bit and to start the car same procedure but reverse. Apply foot break, release ebrake and while still foot on brake put on gear and it still feels the little break. I try not to park uphill that much. Possible problems with the ebrake.
Mkolabin said:
I'll teach you, Andy. Look me up next time you're in western, coastal Canada.
Dont releasr the ebrake untill you put it on park or reverse
 
1 - 12 of 12 Posts
Top