Mustang Evolution Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
Hey guys,

I have an 05 v6 and well, I bought a BAMA tuner not too long ago, but I'm having somewhat of a problem. My car is not running bad whatsoever, but I can't feel any performance upgrades at all. I'm sure it was something within my car's details that was overlooked when I submitted it to BAMA, so I'm not too worried. The tune though has not increased my throttle response at all, even on the racing setting. It still has the same response: I step on the pedal a bit, which is shortly followed by a pause and eventual "wake-up" of the engine, and finally acceleration after about what feels like 2 or so seconds. It's a pretty bad delay. Also, my brother purchased the same tune as well. His 06 mustang has identical upgrades as mine (Ford Racing cold air intake, x-pipe, and GT500 takeoffs), but I can certainly feel the difference. It responds like a champ, it's louder somehow (is it normal for a properly tuned mustang to have a deeper tone?), and certainly faster than mine regarding acceleration.

So, is there anything I can do to get my tuner retuned?

Thanks guys. (If this is in the inappropriate area, I apologize!)
 

·
Registered
Joined
·
98 Posts
Discussion Starter #3
Will do. Appreciate it.
 

·
Registered
Joined
·
2,171 Posts
Hey guys,

I have an 05 v6 and well, I bought a BAMA tuner not too long ago, but I'm having somewhat of a problem. My car is not running bad whatsoever, but I can't feel any performance upgrades at all. I'm sure it was something within my car's details that was overlooked when I submitted it to BAMA, so I'm not too worried. The tune though has not increased my throttle response at all, even on the racing setting. It still has the same response: I step on the pedal a bit, which is shortly followed by a pause and eventual "wake-up" of the engine, and finally acceleration after about what feels like 2 or so seconds. It's a pretty bad delay. Also, my brother purchased the same tune as well. His 06 mustang has identical upgrades as mine (Ford Racing cold air intake, x-pipe, and GT500 takeoffs), but I can certainly feel the difference. It responds like a champ, it's louder somehow (is it normal for a properly tuned mustang to have a deeper tone?), and certainly faster than mine regarding acceleration.

So, is there anything I can do to get my tuner retuned?

Thanks guys. (If this is in the inappropriate area, I apologize!)

Tyrannax,

I agree with you that it does seem like something is up with the tune. Like you already mentioned, its probably something minor like missing info on your tuning sheet or even a simple human error while writing the custom tunes. Either way, I can help get your Mustang running stronger than ever with an easy tune adjustment from Bama.

Have you already contacted them today yet? If not, shoot me over your order number via PM and I'll get things moving for you. Let me know what your current status is and we'll go from there!

Shane
 

·
Registered
Joined
·
98 Posts
Discussion Starter #5
I did, but unfortunately everything checked out from what I could tell. Im not sure what the problem is.
 

·
AmericanMuscle.com
Joined
·
2,878 Posts
I did, but unfortunately everything checked out from what I could tell. Im not sure what the problem is.
We can definitely look a step farther into this for you. Shoot me a PM with your order number included. I'll have my head tuning specialist Mike Wilson contact you directly.

We'll have you shoot over some datalogs and see how everything looks and go from there.

-Dan
 
1 - 6 of 6 Posts
Top