Mustang Evolution Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
214 Posts
Discussion Starter #1
battery light comes on and goes off, had advance auto use a scanner and they did not find anything wrong, any ideas on what to look for?
 

·
Premium Member
Joined
·
19,890 Posts
Bad ground. If not it's your alternator
 

·
Registered
Joined
·
1,563 Posts
Do the old trick and remove the neg side battery with the car running. If the engine dies you have a alternator problem. If it stays running u could have a ground problem or battery problem.
 

·
Registered
Joined
·
65 Posts
There is a diode problem with the alternators. However if you're gauge does not drop it is more likely a battery or battery cable/terminal issue. If you're battery is just say 100 cranking amps low the light will flicker off and on randomly.
 

·
Registered
Joined
·
704 Posts
Mine does it too.
I replaced the terminal cables and got no difference.
Definitely do the negative terminal disconnect and see what happens.
If the car starts reliably, you're probably fine.
Mine's been doing it for a while and I just gave up and deal with it.
If you can, grab a buddy's battery for a day and see if the light flickers still, if it does then you likely have a bad ground.
 

·
Registered
Joined
·
214 Posts
Discussion Starter #6
i bought the battery last year and still have the original alternator with 98,000 miles on it, going to clean terminals and check for loose connections this afternoon, if that doesent fix it i will get an alternator this weekend, thanks for the replies
 

·
Registered
Joined
·
65 Posts
Mine was doing it. 04 GT vert. While I was install a stereo we redid my terminals and did a ten amp charge for two hours. It has been off for almost a week now with more load on the alt. my alt and battery passes load test. Battery showed about 90 cranking amps low. Never slow cranked or anything. I really think it is either the battery or was the batt connections. Car has 100000 miles. Good luck with yours.
 
1 - 7 of 7 Posts
Top