Mustang Evolution Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter · #1 ·
So I got my 96 back together hooked everything up and went to start it up, I put the key in the ignition and all the lights came but when I turned the key I heard a single click then all the lights went dim. I know 100% that there's nothing wrong with the starter. What could it be?
 

·
Registered
Joined
·
616 Posts
That click is the starter solinoid connecting... Most likely your batter is low. Charge your battery and then try.. Have you had to disconnect the battery for some reason?! And maybe taken it out and put it on concreate?! Because concrete will drain your battery
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #3 ·
That click is the starter solinoid connecting... Most likely your batter is low. Charge your battery and then try.. Have you had to disconnect the battery for some reason?! And maybe taken it out and put it on concreate?! Because concrete will drain your battery
I've had it charging all night, I tried again and the engine turned over this time. Tried it a second time and all the lights dimmed and nothing else happened.
 

·
Registered
Joined
·
22 Posts
its either a bad connection ,check your cables make sure there tight and clean.if still not,then sounds like the battery may have gone bad on ya.
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #6 ·
The battery was one I got free, the positive post is loose so I'm guessing I should just get a new battery?
 
1 - 7 of 7 Posts
Top