Mustang Evolution Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
519 Posts
Discussion Starter #1
Anyone have problems with what I guess is fender/dash rattle on their cai? It was fine for 3 months now it makes a harmonic rattle only at just over 1k rpms. So basically when you are driving in traffic or on a road with a 30mph speed zone. I took it to ford to see what it was and they said it was the intake vibrating. They were correct and said they fixed the problem but their fix lasted a day. I took off the filter and retightened things and that lasted a day before it came back.
I've contacted bbk and they are stumped as well. I can't find any points of contact so I am stumped.
 

·
Registered
Joined
·
2,171 Posts
Anyone have problems with what I guess is fender/dash rattle on their cai? It was fine for 3 months now it makes a harmonic rattle only at just over 1k rpms. So basically when you are driving in traffic or on a road with a 30mph speed zone. I took it to ford to see what it was and they said it was the intake vibrating. They were correct and said they fixed the problem but their fix lasted a day. I took off the filter and retightened things and that lasted a day before it came back.
I've contacted bbk and they are stumped as well. I can't find any points of contact so I am stumped.
JAC20,

I actually haven't heard of anyone else have this problem with the 11+ BBK intakes. I do agree that it may be the pins that hold the intake to the fender. Try inserting small pieces of rubber as wedges anywhere this is tight clearances with the fender metal. This should at least help you find the exact spot causing the vibration, just make sure you install one piece at a time, then test.

I'll let you know if I hear of anyone else having this issue and find the route contact causing vibration. Good luck!

Shane
 

·
Registered
Joined
·
519 Posts
Discussion Starter #4
Shane. Will do. I've exhausted every option I could think of. It's now to the point where the car has to be moving to replicate it and its not as bad as it once was. So that is some improvement.

And it's only at 1-1200 rpms or now so I guess the easy fix is to never "floor" it.

I'll see if I can find a rubber piece and try to isolate it. Maybe over Christmas break when I'll have some time and some other options to help.
 

·
Registered
Joined
·
519 Posts
Discussion Starter #5
Should there be any give in it? As in I can lift up and it gives a bit? The end of the filter is touching the heat shield. It's seems tone resting at the very end as if its designed that way.

I'm grasping at straws because I've tried all suggestions now.

I'm about to throw the stock back on and sell it for cheap.
 
1 - 5 of 5 Posts
Top