Mustang Evolution Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So the past few weeks my stock Sync headunit would work on and off.. 2014 Mustang w/ Shaker 500. When it doesn't work it just blinks the time on the head unit display along with the temperature and direction I'm facing. None of the buttons will work.

Has anyone else had this problem before? Would greatly appreciate help before I HAVE to take it to the dealership.

Thanks!
 

·
Registered
Joined
·
1,844 Posts
There were issues... some with the satellite radio & some with Sync.
Try pulling fuse #3 & wait a few minutes then try it.


Sent from my iPhone 7+
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Okay I just pulled fuse #3 and #39 to check if they were blown or not. Both look fine.:confused: I also disconnected the battery and left it for 5 minutes. Still just flashing. I even saw on YouTube where someone put in a CD and it fixed the problem, so I went and dug out a CD but to no avail. :confused: :confused:
 

·
Registered
Joined
·
1,844 Posts
Okay I just pulled fuse #3 and #39 to check if they were blown or not. Both look fine.:confused: I also disconnected the battery and left it for 5 minutes. Still just flashing. I even saw on YouTube where someone put in a CD and it fixed the problem, so I went and dug out a CD but to no avail. :confused: :confused:

There have been radio issues for a while. Pulling fuse 3 was one solution that worked...



Sent from my iPhone 7+ using Mustang Evolution. ?
 

·
Registered
Joined
·
1,844 Posts
Many, many, people have been having this problem...
Another possible fix:

"...it was determined that the APIM hardware unit was done and they had to order a new one. The APIM is the brains of the whole system. It was replaced and all works normal. Lets hope that is the end of that..."

...seems to be a Sync issue.
Sent from my iPhone 7+ using Mustang Evolution. ?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Well damn.. looks like time to go aftermarket. I hear bad things about Raxiom but I want a clean look with double din and also have nav. Any suggestions?
 

·
Premium Member
Joined
·
5,240 Posts
So is it within the 3/36? (I can't tell from what you typed) IF it is under wtty and not caused by anything aftermarket they shouldn't charge you. If it's under wtty and they find you added an amp and shorted out the system then they will can/should charge you for their time. Remember if it is under wtty and one dealer is a PITA go to another. The wtty is from Ford not the selling dealer.
 

·
Registered
Joined
·
1,844 Posts
Lots of issues with "dead" radios. Ford doesn't know why, tho.


Sent from my iPhone 7+ using Mustang Evolution. ?
 

·
Registered
Joined
·
1 Posts
So the past few weeks my stock Sync headunit would work on and off.. 2014 Mustang w/ Shaker 500. When it doesn't work it just blinks the time on the head unit display along with the temperature and direction I'm facing. None of the buttons will work.

Has anyone else had this problem before? Would greatly appreciate help before I HAVE to take it to the dealership.

Thanks!
I’m having the same issue with mine right now but it started after I got new wheels out on they either didn’t connect something back correctly or something cause it started 30 minutes after I pulled off
 

·
Registered
Joined
·
1 Posts
I spent countless hours looking for a solution. My still factory radio just has a blinking clock. Would hear a pop like a wire or fuse blowning then radio would stop couldn't do anything but turn it off but wouldn't turn back on for sometimes about 10 15 mins or so or sometimes hours even more than a day. This went on for a couple of weeks till now it does nothing but taunt me with a blinking clock. All I could find out was to take the whole middle console off to be able to take most of the dash off to take the outer mount off to get to the stereo mount. Then take radio out. Take the shell off take out the cpu mother board then take in house and bake in oven for 5 to 10 mins on 350. This will supposedly heat up all the soldering points and spread it back out fixing any disconnections. Even though they just want your money and to gouge your eyes out ford said they couldn't say for sure. Bull **** ya lying ****. You coulda shot me at least one thing to check. So i almost have the radio out ill post again if it actually works
 

·
Registered
Joined
·
2 Posts
So I figured this out I hope that it helps you guys you know that panel in your floorboard so that's constantly coming off and people are constantly kicking it my all my doors were a jar and I didn't understand why it's because there's like one of those wires has like the switch thing that locks it in so when those wires become loose it also causes your radio not to work I'm not sure which exactly one it is but I know that every time my radio like starts blinking I get down there and I push all those wires in and make sure they're all connected properly and if it doesn't work right away when I turn my car off so it for a significant amount of time and turn it back on it starts to work again so I really really hope this helps you guys and let me know I know it's kind of it's kind of an Old Post
 
1 - 17 of 17 Posts
Top