Mustang Evolution Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
812 Posts
Discussion Starter #1
Hi All, I have an 08 GT & I'm having trouble with the Brake & Traction Control light on the dash coming on. About 2 months ago the car was fine. I think someone tried to steal my wheels as one day I was driving to work & I heard a loud noise like something broke & the car started shaking. 2- of the wheel studs in the drivers side rear wheel broke off & the other 3 Lug Nuts were all real loose.
I replaced the 2 studs but when I pounded them out a stud must of hit that gear / sprocket looking deal (for the ABS Sensor) on the wheel bearing hub & made it crooked. That made the ABS & Traction Control light on the dash come on. Straightened out the sprocket & those 2 light went off. After driving a couple days the Brake & Traction Light came on. Those 2 dash lights come on every day while I'm driving the car. But once I get home & let the car sit awhile the lights go back off & don't come back on till I'm driving for awhile.
I've bled the system & replaced the rear brake pads even though they didn't really need it. I'm having one heck of a time trying to find the problem. Anyone have any ideas ??? Firestone wants $100 just to hook up an ABS Code Reader & give me a code. $30 - $40 would have been reasonable but $100 ? Needless to say I'll never use Firestone products after that.
An OBD2 Code Reader wont work...it has to be an ABS Code Reader I'm told.
Any idea what my brake problem could be ? I'm lost !!!!
 
K

·
Guest
Joined
·
0 Posts
From what you have mentioned, have you tried replacing that ABS sensor? I do not believe they are expensive. I think the ABS sensors go for $40-$50 per wheel - new. Just spit balling it since no one has suggested anything else and it is a cheap part.

And if you do swap it, disconnect the battery for 1 hour to let the ECU reset/clear existing codes.
 

·
Registered
Joined
·
812 Posts
Discussion Starter #3
I don't think it's the sensor. I recently found that if I pump the brake up each & every time I get in the car before I start it the brake light on the dash stays off. I forget to pump it up one time & the light comes on. I've bled the brakes several times & it seems like air is getting in the line again somehow. I'm going to take it in & have the system purged & hope that works.
If not I'm thinking the Booster or Master Cylinder might have an issue. I wonder if a bad brake fluid cap could cause this ???
 
K

·
Guest
Joined
·
0 Posts
Have you checked the brake lines to make sure there were no small leaks? Also, have you checked the brake booster?

If it goes away with pumping the brakes, i would assume brake booster or vacuum leak in a hose somewhere. Cant remember if the brake system on those cars has a check valve...
 

·
Registered
Joined
·
812 Posts
Discussion Starter #5
No Leakage near the calipers but I haven't followed the lines. Brake Fluid is staying full.
Not sure how to check the booster....but seen something on that in my Chilton's so I plan to check it out this weekend if I don't have to work.
 
1 - 5 of 5 Posts
Top