Mustang Evolution Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
Hello again everyone
When driving on the highway (75-80 mph) everything is fine, however, if I floor it to pass someone I get a "burning" smell from the front of the car. It doesn't smell like gasoline or anything in particular.
I expressed my concerns at my local dealer when I got the oil changed and they said that they didn't see anything but to keep an eye on it.
So have any of you guys experienced anything similar or have any idea what it might be?
 

·
Registered
Joined
·
443 Posts
This happens to mine but when i floor it and then when i get home and park it i can smell that burning odor. I don't pay too much attention because i figure it's just from straining my engine so much at times
 

·
Registered
Joined
·
3,713 Posts
That happened to me too...
but that's when I pushed it really hard.
REALLY REALLY HARD!!!
It used to do it a lot (mainly when the car was breaking in)
I'm at 12k now, and it never happens when I floor it.
unless i take it as hard as I did yesterday :p
 

·
Registered
Joined
·
3,463 Posts
It's the oil going into the engine from the valve hose thing on the passenger side. Very hard and aggressive driving did that to mine. The solution is to get the oil catch can and the problem stops. Also if auto it's the transmission kinda burning a little lol just my experience.
 

·
Registered
Joined
·
484 Posts
Oil catch can has not resolved it. It smells like burned oil/charcoal. I can get the smell EVERY SINGLE TIME that I accelerate hard to pass or merge.
 

·
Registered
Joined
·
4,019 Posts
Mine don't have any smell at all

I'm wondering if you may have a slight exhaust leak. It will be fine around town but when you are up in the high RPM the extra pressure allows the exhaust to escape at a connecting point causing the smell you describe.

Ronnie
 

·
Registered
Joined
·
3,463 Posts
Oil catch can has not resolved it. It smells like burned oil/charcoal. I can get the smell EVERY SINGLE TIME that I accelerate hard to pass or merge.
If you're auto it's the tranny. I cruised my car at 100 and then kept redlining it to pass people. It had this funky smell. The oil catch can resolved it but I noticed also my tranny shifted like absolute slush when I was doing that.
 

·
Registered
Joined
·
4,019 Posts
Your transmission has a problem.

If your having that problem something is very wrong. The transmissions in our 3.7 Mustangs are the exact same one's they use in the GT's, And The Roush stage three also uses this automatic if you order it. It is a very sturdy transmission and really hard to mess up.

You may have hurt it when you had your accident a while back.

Ronnie
 

·
Registered
Joined
·
484 Posts
I'm wondering if you may have a slight exhaust leak. It will be fine around town but when you are up in the high RPM the extra pressure allows the exhaust to escape at a connecting point causing the smell you describe.

Ronnie
I think that may be it. Explorers had a similar issue
 

·
Registered
Joined
·
4,516 Posts
This is true as mine had a hairdryer smell to it when she was new. It has completely gone now (15000km) later but the first 8-10 it would almost always happen when I'd push her.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #13
Wow I definitely wasn't expecting this many replies! I'm glad that I'm not the only one that's experiencing it
I didn't consider it being oil haha
It definitely only happens when I push it hard, and it usually goes away within a minute or two.
My car is fairly new. I got it at the end of May, so it's not brand new but it's not old
 

·
Registered
Joined
·
95 Posts
As another data point: I've noticed it too when I really get on it but I have a manual so it supports the theory that it isn't the transmission.
 

·
Registered
Joined
·
3,463 Posts
It has to be oil or something getting into the top manifold. Mine stopped mainly when I got the oil catch can. Which is 1/2 full and I've only had it for 2 weeks!
 

·
Admin
Joined
·
5,822 Posts
I have the 3.7 V6, and automatic transmission. I drive 300 to 450 miles a week on my Mustang, and I have no oil smelling issues. I drive at constant highway speeds, and "push it" to pass vehicles. Again, no oil or other smells when I do this. I too have a catch can, but even before that was installed, I did not experience these smells.

I'd inspect the area around the oil filter for spills. That filter likes to spill off oil when it's removed (you know this if you do your own oil changes). Perhaps there's some oil on the frame, or engine in this area that's burning a bit when the engine is warm.
 

·
Registered
Joined
·
333 Posts
I used to get this smell, but mine stopped at around 10k miles. I too thought it was oil, but it doesn't do it anymore so I believe that it's the sealants and whatnot from when it's new.
 

·
Registered
Joined
·
3,463 Posts
Well also check your coolant guys, when I checked mine last after this little incident, my top reservoir was bone dry and it took 1 whole bottle to fill it back up. Now my car runs correctly and also no burning smell. It wasn't oil, but to me was a weird material like burning but with all that I did at the same time; the new modifications
 
1 - 20 of 28 Posts
Top