Mustang Evolution Forum banner

1 - 20 of 21 Posts

·
Banned
Joined
·
102 Posts
Discussion Starter · #1 ·
When traveling down the road if you put it in neutral and use break to slow down instead of down shifting the car dies. Its an 04' mach1. I nearly wrecked it due to this cause i put it in neutral to slow down to go around a curve and it died and steering wheel locked. Anyone else have an issue like this?

---------- Post added at 08:17 PM ---------- Previous post was at 08:16 PM ----------

Only happens when in motion... roughly 40 mph or higher
 

·
Lorraine's driver
Joined
·
8,208 Posts
When traveling down the road if you put it in neutral and use break to slow down instead of down shifting the car dies. Its an 04' mach1. I nearly wrecked it due to this cause i put it in neutral to slow down to go around a curve and it died and steering wheel locked. Anyone else have an issue like this?

---------- Post added at 08:17 PM ---------- Previous post was at 08:16 PM ----------

Only happens when in motion... roughly 40 mph or higher
What CAI do you have? I've heard of this happening when a certain cold air kit is used with the shaker setup.
 

·
Premium Member
Joined
·
3,535 Posts
No check engine light (cel)?
 

·
Lorraine's driver
Joined
·
8,208 Posts
Some of the Mach's have trouble when the MAF screen is removed, and this could be how yours is acting. Of course, this is only if you have an aftermarket CAI. If you have the stock air intake setup, there is something else going on.
 

·
Banned
Joined
·
102 Posts
Discussion Starter · #6 ·
She has the k&n cai on it and no check engine light... i thought maybe neutral switch but why only when in motion
 

·
Lorraine's driver
Joined
·
8,208 Posts
She has the k&n cai on it and no check engine light... i thought maybe neutral switch but why only when in motion
You could try the idle re-learn.

Disconnect NEG from battery for 20 minutes

Reconnect the battery and start car, let idle as soon engine gets to operating temp, Let it idle a little over a minute

Turn on A/C to MAX, let idle little over a minute, turn off A/C

Then drive the car for at least 10 miles
 

·
Premium Member
Joined
·
3,535 Posts
There is no missing or nothing else that seems odd? I'm with the idle relearn. It is definitely worth a try. How is regular idle?
 

·
Premium Member
Joined
·
3,535 Posts
Maybe idle air control module. Keeps car at proper idle
Agree. Check and clean the idle air control valve. How long you had that cai?
 

·
Banned
Joined
·
102 Posts
Discussion Starter · #12 ·
There was also 1 instance where she was driving 65 mph ish and all the sudden it started idling very high... she pulled over and let it sit and it still continued. When she pushed in on clutch to shift it would also rev real high. After letting it sit a few hours it went back to normal.

---------- Post added at 09:21 PM ---------- Previous post was at 09:20 PM ----------

She bought the car in august and it was already on the car
 

·
Lorraine's driver
Joined
·
8,208 Posts
There was also 1 instance where she was driving 65 mph ish and all the sudden it started idling very high... she pulled over and let it sit and it still continued. When she pushed in on clutch to shift it would also rev real high. After letting it sit a few hours it went back to normal.

---------- Post added at 09:21 PM ---------- Previous post was at 09:20 PM ----------

She bought the car in august and it was already on the car
I'd try the I'd,e re-learn first. If it continues, you can pop off the idle air control valve and see how dirty it looks. Be careful not to damage the gasket when you take it off. I used throttle body cleaner on mine. It was working okay for me, just some maintenance, but mine looked dirty with some carbon looking residue.

View attachment 89250
^It's on the firewall side of the intake near the throttle body.
 

·
Lorraine's driver
Joined
·
8,208 Posts
BTW, please forgive my salty engine. I freaked out a few minutes ago when I took this pic. I had no idea it got salty in my engine bay from the road. :(
 

·
Premium Member
Joined
·
3,535 Posts
I'd try the I'd,e re-learn first. If it continues, you can pop off the idle air control valve and see how dirty it looks. Be careful not to damage the gasket when you take it off. I used throttle body cleaner on mine. It was working okay for me, just some maintenance, but mine looked dirty with some carbon looking residue.

^It's on the firewall side of the intake near the throttle body.
+1 and awesome pic! Mines dirtier. Will pay for cleaning. Lol.
 

·
Registered
Joined
·
1,013 Posts
Tps maybe?
 

·
Registered
Joined
·
869 Posts
Ever find an answer? Mine does it to (08 GT) ill be coming to a stop and it will die. Found out if i downshift then clutch and break it won't do it as often. Still looking for an answer.
 
1 - 20 of 21 Posts
Top