Mustang Evolution Forum banner

1 - 20 of 65 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter #1
About 2 weeks ago I was showing my buddy my exhaust and we decided to start my car up. I have long tube headers with off road x pipe and borla axelbacks. It was a cold start and as soon as he started it he stomped on the gas. After that the car would idle up and down on its own. I figured it would go away on its own bit it never did. It wasn't too bad it was just barely moving up and down. Anyways last week I went to get my boss 302 Intake manifold installed and I got it returned with Bama and at first it was alright and the idling seemed to be fixed. Anyways I live like 100 miles away and it says to drive normally for about 50 miles to get the intake broke into I suppose. I drove on the highway at the speed limit 70mph the whole way. Got home and filled it up and then the car wouldn't start at the gas station I was worried but after several tries it finally started but when it did it wanted to start out and I gave it some gas to keep it going. After that it has been starting just fine but it's back to idling rough to the point where It stalls out if I let it. I called Bama and they said they forgot to include the long tube headers in the tunes so I got the new ones and put them on and it idles a bit better bit it's still rough. I haven't turned it back to stock but I will do that when I get home today and see if it's still doing it. I got the codes p2195 and p2197. Just wanting to know if anyone has had these problems before and If I could get some help to get my car running normal. Please and thank you.

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
157 Posts
Discussion Starter #2
I know I have horrible grammar.

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
157 Posts
Discussion Starter #3
Also I did some research on the error codes and most say it could be the pcv hose. I have the jlt oil separator I will also inspect that when I get home

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
3,699 Posts
Sounds like you killed both of the front o2 sensors. This is probably because of your longtube headers. Which ones are they? Oh and I would strongly advise against driving the car until they're replaced.

No tune revision is needed for longtubes FYI. And there's no such thing as breaking in an intake manifold.

Not running the extensions for the front o2's are you?
 

·
Registered
Joined
·
157 Posts
Discussion Starter #5
I have the jba longtubes. And the guys at Bama told me they hadn't included the longtubes in the tune so that's what was causing the idling. And extensions for the front o2s? I don't even know I took my car to get the longtunes installed and idk if they were put on or if they are included with the longtubes. So you're saying I just need to replace my 02 sensors?

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
3,699 Posts
Don't listen to the guys at Bama. There is no tune revision needed for longtubes on these cars. That's a common mistake. The first thing you need to do is determine if the shop that installed the longtubes installed o2 extensions. If so get them off ASAP. Then we'll go from there.

Do the JBA longtubes have the o2's in the 9:00 and 3:00 position?
 

·
Registered
Joined
·
157 Posts
Discussion Starter #7
I'm gonna take a look at it when I get home and I'll get back to you. Also I got them installed back in like February and hadn't had any issues until now

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
157 Posts
Discussion Starter #8
Alright so the car has the o2 sensors towards the end of the longtubes like you said. At the 3:00 and at 9:00. Are they not supposed to be there?

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
3,699 Posts
They're supposed to be there but that's the reason for most of the o2 problems out there. Moisture gets trapped in there and and has nowhere to go. One of the reasons the Kooks are the way to go. Some guys have had that hole welded up and had the sensors relocated to the 10:00 and 2:00 position.

I still need to know if you're running the o2 extensions. That's very important.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #10
I honestly don't know. I don't think so because I never bought any and I don't think any came with the longtubes and the shop didn't tell me anything about installing extensions on the sensors. Also when I got the longtubes installed I has the catted x pipe and now I have the off road x pipe but idk if that matters.

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
3,699 Posts
The cats have no bearing on this. These are the upstream o2's. The important ones.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #12
So I should just get the 02 sensors replaced? With or without extensions? Are extensions just bad? Also I used the car to go to the store and I noticed the rpms get stuck in at around 1500 rpm in 1st and 2nd gear and won't go down unless I hit the breaks. I forgot to point that out earlier

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
3,699 Posts
Replacing the O2 sensors should do it. But this will happen again because of the headers.
Never ever use the extensions. Are you running E85? That makes things worst.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #14
Nope I'm just running the 93 octane fuel

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app

---------- Post added at 11:35 PM ---------- Previous post was at 11:34 PM ----------

So what happens with the headers? Do they burn off the sensors or what?

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
9,586 Posts
Its definitely your O2's. I have to replace mine often, same exact codes.

Also look into someone else for a tune also. Bc them saying you need a retune for the long tubes is not correct. Main thing the tune does is shut off the rear o2's.

For example. If you go with Lund, on every single one of his tunes he shuts off the rear o2's. Even if you have cats.

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
157 Posts
Discussion Starter #16
Its definitely your O2's. I have to replace mine often, same exact codes.

Also look into someone else for a tune also. Bc them saying you need a retune for the long tubes is not correct. Main thing the tune does is shut off the rear o2's.

For example. If you go with Lund, on every single one of his tunes he shuts off the rear o2's. Even if you have cats.

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
How often do you replace your 02 sensors? What are the best sensors/brand to get?

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
9,586 Posts
Also the best way to tell is to do a idle log. Will tell you if the O2's are bad. For future reference

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
9,586 Posts
How often do you replace your 02 sensors? What are the best sensors/brand to get?

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
So far 3 times. Mine is due to e85 and c116.

I use the NTK ones from AM

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
157 Posts
Discussion Starter #19
Replacing the O2 sensors should do it. But this will happen again because of the headers.
Never ever use the extensions. Are you running E85? That makes things worst.
Why are extensions bad?

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 

·
Registered
Joined
·
157 Posts
Discussion Starter #20
So far 3 times. Mine is due to e85 and c116.

I use the NTK ones from AM

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
Aren't those like 150 for each one???

Sent from my SAMSUNG-SM-G870A using Mustang Evolution mobile app
 
1 - 20 of 65 Posts
Top