Mustang Evolution Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
502 Posts
Discussion Starter #1
So I notice my car shakes/ stumble and idles a little rough. It's noticeable enought that you can feel it when sitting still and see the shifter move. All so noticed the other day I had my car running and was standing near the back and there was a high pitched humming coming from the rear end that seemed to change when the car stumbled a little. Don't know if these are tied together or if there's vacuum lines down there but if anyone has an idea what could be causing this please lemme know.its driving me crazy
 

·
Registered
Joined
·
502 Posts
Discussion Starter #3
Already did the fuel filter a while ago. It doesn't really hesitate or anything while driving just at idle
 

·
Registered
Joined
·
502 Posts
Discussion Starter #5
Done sea foam already and I have the stock shifter it's bone stock. It's my second stang so I know a bit about them just can't figure this out
 

·
Registered
Joined
·
420 Posts
Dgerow12 said:
Done sea foam already and I have the stock shifter it's bone stock. It's my second stang so I know a bit about them just can't figure this out
Is there anyway you can do a smoke test on it to check for vacuum leaks
From what I've seen sometimes if you run rough at idle and fine while driving, I've seen rich running conditions at idle like a sticking injector or something
 

·
Registered
Joined
·
502 Posts
Discussion Starter #7
I'll try to get one done there not cheap around here. And just as an update my idle really doesn't fluctuate except for when I'm driving and I am coming to a stop and push the clutch in it sometimes tries to stall out. I'm wondering if its my iac
 

·
Registered
Joined
·
420 Posts
Dgerow12 said:
I'll try to get one done there not cheap around here. And just as an update my idle really doesn't fluctuate except for when I'm driving and I am coming to a stop and push the clutch in it sometimes tries to stall out. I'm wondering if its my iac
It could be your iac going out as well
 

·
Registered
Joined
·
1,147 Posts
twotone01 said:
It could be your iac going out as well
Yeah my iac barely runs right now. Say I'm driving at 2500rpm, it will just sit there even when I push in the clutch and throw it in to neutral. Is it misfiring or just shaking?
 

·
Registered
Joined
·
502 Posts
Discussion Starter #10
No misfire just shakes. I got an 02 sensor code a while ago but then it went away and never came back. I wonder if one of my 02's is going out
 

·
Registered
Joined
·
45 Posts
Your wrecking your engine. Get the front o2 sensors replaced. Your make the engine run hard and is you get an cold/ air intake I bet it will go Down
 

·
Registered
Joined
·
502 Posts
Discussion Starter #13
V6stang6272 said:
Your wrecking your engine. Get the front o2 sensors replaced. Your make the engine run hard and is you get an cold/ air intake I bet it will go Down
Ok first off bro I've rebuilt engines and I know how to work on cars. I know more about engine control systems than a lot of people and I know how to trouble shoot. My car is running fine it just stumbles on idle occasionally. So don't even try telling me I'm ruining my engine I prolly know more about these engines than you. I HAD a code for about 3 hrs about two months ago and it went away after I drove my car. Common cause for the code was not giving the car time to warm up before driving it aka I started right up and took off down the road like a bat outta hell. I've never had any other code. An oxygen sensor can cause a slight issue in air fuel which could be enough to cause a slight stumble during idle. So think about who your talking to before you try telling someone their ruining thier engine when in reality you dont know anything about thier car because you dont drive it. And Joey that's interesting that you say they because my throw out bearing is also on its way out. RANT OVER
 

·
Registered
Joined
·
1,147 Posts
Dgerow12 said:
No misfire just shakes. I got an 02 sensor code a while ago but then it went away and never came back. I wonder if one of my 02's is going out
Well If it had an o2 code then just replace the bad o2, can't hurt. Mine stumbles a little at idle as well. But it's either my IAC or o2s, plus I have a bad cat. If t fixes your problem let me know, then ill replace mine :)
 

·
Registered
Joined
·
502 Posts
Discussion Starter #15
Well It feels like a very slight shake but my Rpms never change. The needle doesn't even twitch when it's idling so I'm wondering if its the throw out bearing about to sh** the bed.
 

·
Registered
Joined
·
876 Posts
Dgerow12 said:
Well It feels like a very slight shake but my Rpms never change. The needle doesn't even twitch when it's idling so I'm wondering if its the throw out bearing about to sh** the bed.
Id say yeah check that mine did this shaking thing when id be at a stop and the needle didnt move the the next day i hear this horrible screeching sound because the throwout bearing went out.. i guess its a common thing for are cars.. or so ive heard
 

·
Registered
Joined
·
1,147 Posts
Id say yeah check that mine did this shaking thing when id be at a stop and the needle didnt move the the next day i hear this horrible screeching sound because the throwout bearing went out.. i guess its a common thing for are cars.. or so ive heard
yeah mine is crap too. whenever i let out the clutch, i can hear squeaking but when its disengaged its nice and quiet
 

·
Registered
Joined
·
502 Posts
Discussion Starter #19
Mine doesn't hesitate like yours did tho. There's not a change in how it runs except for the slight change in idle
 
1 - 20 of 21 Posts
Top