Mustang Evolution Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
1,895 Posts
Discussion Starter #1
As all of you know my fuel pump died.

My buddy "matt'sdrag95" gave me his gas tank which had his stock fuel pump in it. He said it worked fine.
So i got it. I dropped my tank, and i was going to switch pumps, but his tank had alot less rust and wear on it so i just used his tank.

About a month ago, i took my old tank off. Left the lines down ect cause i never had enough time to go out there and put the new tank in.
I got out of work early today so i raised the new tank up.
Plugged in the harness. (i bought a new rubber gasket where the spout neck goes into the gas tank cause the other one was cracking. Stuck that in Stuck the filler neck in. Put in that white thing that goes in the hole have no idea what that is. Pluged in the fuel lines, clamed them.

Bolted up the tank. Bolted up the filler neck. Filled it up with as much gas as i could fit in my hand held tank. (6.5 gallons)

Tried to start it.
It goes like it has the power to start but it doesnt turn over.
I also plugged back in the fuel pump plug that you unplug to release the gas pressure)

I knew there was no pressure and it would take a while, but i kept cranking it. waited 5 minutes cranked it alot again, while pushing the gas...

still it just cranks, but it wont fire up.
Dont know what else to do, what else to check...

:(
:-?

help?
 

·
Banned
Joined
·
11,872 Posts
turn the car to the on positon and leave it there for a couple of minutes. Then try to crank it.

**A shot in the dark as well**
 

·
Registered
Joined
·
1,895 Posts
Discussion Starter #5
Brent said:
turn the car to the on positon and leave it there for a couple of minutes. Then try to crank it.

**A shot in the dark as well**

what would that do?
 

·
Premium Member
Joined
·
19,890 Posts
Ha who knows, but it's worth a shot. If nothing else try disconnecting you battery to reset your computer. Anything's worth a shot to save some money. Just some advice from ppl though.
 

·
Premium Member
Joined
·
19,890 Posts
Ha sorry man, can't help you very much on that one...hm...I sure wish someone who knew more about this than me would post....People act like they have something else to do besides help people on here.
 

·
Premium Member
Joined
·
5,187 Posts
OK Charles you need a helper. to do some things for you while you check things. do you have fuel to the motor, do you here the pump. go to the shrader valve on the fuel rail and see it you are getting anything including air out it when the key is in the on position.
 

·
Registered
Joined
·
1,895 Posts
Discussion Starter #10
My dad put the key in the on position yesterday when it wasnt starting, i laied under the tank, and i put my ear next to the filler neck.

Both times, I didnt know if i could hear the pump.
If it was there it was very faint.

Ill check the shrader vavle.
 

·
Registered
Joined
·
1,895 Posts
Discussion Starter #14
Ok corey, I checked the sharder valve, nothing, no air, no fuel, no pressure when i move the valve at all.

I have a core remover at work, ill bring it home remove the core and see if anything comes out.

I tried starting it and pumping gas in it a few times. But nothing no pressure in that line at all.

Could it be the sending unit? Or Just the pump?

And If iam going to be spending money on a new pump, i might as well get the one that i want now so i dont have to do this all over again.
 
1 - 20 of 29 Posts
Top