Mustang Evolution Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,940 Posts
Discussion Starter · #1 ·
Hi guys need your help pls.. I just had installed the tuner for 89 octane performance tune, and check engine light came on and its reading too lean. What should i do? Is this serious? Can i just clear it using the tuner? This happen right after i put the tune. Thanks
 

·
Registered
Joined
·
1,940 Posts
Discussion Starter · #3 ·

·
Registered
Joined
·
1,940 Posts
Discussion Starter · #5 ·
What tune were you running before?
I was running hybrid tune and changed it too street and after long drive changed it to performance tune since the hybrid tune does not make any difference for me. And im using 89 octane which is for my hybrid and performance tune.
 

·
Registered
Joined
·
982 Posts
I was running hybrid tune and changed it too street and after long drive changed it to performance tune since the hybrid tune does not make any difference for me. And im using 89 octane which is for my hybrid and performance tune.
Clear it an switch tunes to see if that helps could be a tune issue if you didn't have the problem before
 

·
Registered
Joined
·
1,940 Posts
Discussion Starter · #7 ·
Clear it an switch tunes to see if that helps could be a tune issue if you didn't have the problem before
I cleared it already and so far the light is not going on. Thanks
 

·
Registered
Joined
·
224 Posts
Hi guys need your help pls.. I just had installed the tuner for 89 octane performance tune, and check engine light came on and its reading too lean. What should i do? Is this serious? Can i just clear it using the tuner? This happen right after i put the tune. Thanks
Mine does that once in a while if I go back and forth between tunes. Usually just clear the codes. And it doesn't come back on
 
1 - 8 of 8 Posts
Top