Mustang Evolution Forum banner

1 - 20 of 133 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
So when I first bought my mustang it had dumped exhaust system. And the check engine was off. I thought it had the engine delete wires that replace the converters but doesn't. How do I fix this problem? I disconnected the maf to see if it would turn on but no.
 

·
Registered
Joined
·
598 Posts
Israel98 said:
So when I first bought my mustang it had dumped exhaust system. And the check engine was off. I thought it had the engine delete wires that replace the converters but doesn't. How do I fix this problem? I disconnected the maf to see if it would turn on but no.
What do you mean engine delete wires? Are you talking about MIL eliminators? Is your check engine light on now or is it still off? Do you have an o/r mid pipe? Having dumped exhaust itself shouldn't make the CEL come on if it's dumped after the mufflers
 

·
Registered
Joined
·
98 Posts
Discussion Starter #3
JetLife 01GT said:
What do you mean engine delete wires? Are you talking about MIL eliminators? Is your check engine light on now or is it still off? Do you have an o/r mid pipe? Having dumped exhaust itself shouldn't make the CEL come on if it's dumped after the mufflers
Yeah the eliminators. My light is off and I have straight pipes. It has no converters.
 

·
Registered
Joined
·
598 Posts
So what's the problem? Don't mean that in a rude way I just seriously don't know. Are you saying cant ever get the CEL to come on? So like ur worried if you have a problem with the motor the CEL won't come on? The MIL eliminators won't cause ur CEL to stay off if you have other issues. The MIL's only change what goes on with ur rear o2 sensors nothing else
 

·
Registered
Joined
·
98 Posts
Discussion Starter #5
Yeah it can't ever get on so I'm just worried tht when there is something wrong with it I might not kno the problem. I think there might be something wrong with it now but I'm not sure idk where to start
 

·
Registered
Joined
·
598 Posts
Israel98 said:
Yeah it can't ever get on so I'm just worried tht when there is something wrong with it I might not kno the problem. I think there might be something wrong with it now but I'm not sure idk where to start

MILs won't cause ur CEL to stay off when there are other issues. That being said ur CEL also won't come on for every issue with the engine that you have. What are the symptoms you are experiencing?
 

·
Registered
Joined
·
98 Posts
Discussion Starter #7
I think the egr valve or the idle control is bad or maybe the maf but I already tried like leaving the gas cap off and doing other operations to see if it turned on but no.
 

·
Registered
Joined
·
598 Posts
Israel98 said:
I think the egr valve or the idle control is bad or maybe the maf but I already tried like leaving the gas cap off and doing other operations to see if it turned on but no.
Make another thread about that. Someone on here with more trouble shooting knowledge will chime in and help ya out man
 

·
Registered
Joined
·
1,013 Posts
Ok so im just jumping in on it.....take it to an autozone and get the scanner to read if there is atleast pending codes on it like for maf sensor and such when u disconnected them. If the scanner cant read anything like it cant communicate with the pcm there is where u start. Id start with a wiring diagram to see where it gets power from and if it shows up independently from the comp. Imma post a diagram soon as i get off the mobile app.
 

·
Registered
Joined
·
1,013 Posts
here is the diagram so far
 

Attachments

·
Registered
Joined
·
98 Posts
Discussion Starter #13
1996mustang said:
Ok so im just jumping in on it.....take it to an autozone and get the scanner to read if there is atleast pending codes on it like for maf sensor and such when u disconnected them. If the scanner cant read anything like it cant communicate with the pcm there is where u start. Id start with a wiring diagram to see where it gets power from and if it shows up independently from the comp. Imma post a diagram soon as i get off the mobile app.
The scanner couldn't read anything. After I'm off of work tommorow I'll take a look at the diagram and start from there. Do you happen to have a URL or something?
 

·
Registered
Joined
·
1,013 Posts
I used alldata to pull it up if anything just google instrument cluster electrical diagram and u should find a image for it

---------- Post added at 09:37 PM ---------- Previous post was at 09:36 PM ----------

When u said it didnt pull anything up u mean it says it couldnt communicate with the computer or it said no codes?
 

·
Registered
Joined
·
98 Posts
Discussion Starter #15
1996mustang said:
I used alldata to pull it up if anything just google instrument cluster electrical diagram and u should find a image for it

---------- Post added at 09:37 PM ---------- Previous post was at 09:36 PM ----------

When u said it didnt pull anything up u mean it says it couldnt communicate with the computer or it said no codes?
Ok thanks. And it said it couldn't communicate with it. Is that a bad sign?
 

·
Registered
Joined
·
1,013 Posts
Couldnt communicate can narrow things down alot. It means the scanner cant read the pcm at all. This could be due to a cigarette lighter fuse or a fuse thats integrated in the dtc circuit (dtc is the term for the obd that sometimes shows on fuse box) or it could very well be that the obd connection is cut or the pin #4 on the pcm for the cel is unplugged. I would start with the cigarette fuse. Idk if ur lighter works but if it doesnt try replacing that fuse. Ill research the diagrams for u to see if there is a fuse that goes to the obd connector. Other than that go thru the cables on the obd connector and check to see pcm connections too. Ill have the info soon as i get home.


and its dlc i meant not dtc
 

·
Registered
Joined
·
1,013 Posts
here is the connector view for the dlc connector.

and on the pcm its pin #2 for the one that goes from the pcm to the dlc connector
 

Attachments

·
Registered
Joined
·
98 Posts
Discussion Starter #18
1996mustang said:
Couldnt communicate can narrow things down alot. It means the scanner cant read the pcm at all. This could be due to a cigarette lighter fuse or a fuse thats integrated in the dtc circuit (dtc is the term for the obd that sometimes shows on fuse box) or it could very well be that the obd connection is cut or the pin #4 on the pcm for the cel is unplugged. I would start with the cigarette fuse. Idk if ur lighter works but if it doesnt try replacing that fuse. Ill research the diagrams for u to see if there is a fuse that goes to the obd connector. Other than that go thru the cables on the obd connector and check to see pcm connections too. Ill have the info soon as i get home.

and its dlc i meant not dtc
Wow yeah it did. Where do I find that fuse box? And I noticed I don't have a cigarette lighter? There's just the hole were it used to be....
 

·
Registered
Joined
·
98 Posts
Discussion Starter #19
Israel98 said:
Wow yeah it did. Where do I find that fuse box? And I noticed I don't have a cigarette lighter? There's just the hole were it used to be....
I mean the fuse for the cigarette lighter
 

·
Registered
Joined
·
1,013 Posts
Fuse is in the hood fise box. Its a 20 amp if i remember
 
1 - 20 of 133 Posts
Top