Mustang Evolution Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Need some advice on a problem that’s just surfaced on my 2016 GT. I have the Synch 3 system and it started malfunctioning in two ways – my clock doesn’t work (when I start the car it displays correct time but won’t advance) and I can’t access the Nav system to display at all. I get audio feedback when I select it on screen but nothing else. Also voice commands will allow me to change state when asking for address but won’t go further than that. All other Synch 3 functions seem to work.

I have two specific questions: 1) is there a fix that doesn’t require me to use dealer service, which I’m guessing will be costly and 2) Would upgrading to Apple Car Play, which my dealer tells me would be a $250 cost, fix the problem?

Any help would be appreciated.

Thanks,
 

·
Registered
Joined
·
318 Posts
Not sure what's causing your issue but Carplay and Android Auto are just a software upgrade that you can down load and install your self. You may want to go under Settings, General and do a Master Reset.

You need at least version 2.2, check under Settings, General, About Sync. The current version is 3.0

Dave
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I tried both upgrading Sync 3 via automatic updates over wifi and downloading via USB from ford's owner site. Neither works. I get a "no update available error on the Ford site" but I'm still showing Sync 3 version 1 in the car. I did get the nav system back using the master reset but no CarPlay. (Thanks for that suggestion) Any thoughts here?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Not too long ago. And yes it does seem like I'm starting to see a number of issues. I'm chalking them up to hitting 40,000 miles rather than the warranty expiring. I was fortunate enough to have the A/C go out at 35,800 so that replacement was covered.
 

·
Registered
Joined
·
318 Posts
I tried both upgrading Sync 3 via automatic updates over wifi and downloading via USB from ford's owner site. Neither works. I get a "no update available error on the Ford site" but I'm still showing Sync 3 version 1 in the car. I did get the nav system back using the master reset but no CarPlay. (Thanks for that suggestion) Any thoughts here?
If you go to the Mustang6G forum there is a thread on updating. They did have the files to update to version 3.0 posted. I did my 17 that way even though the Sync site didn't have it.

Dave
 
1 - 6 of 6 Posts
Top