Mustang Evolution Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,552 Posts
Discussion Starter #1
I have heard of this, but have never experienced it. That is until last night that I know of, not sure its what happened, you guys tell me.....

I started on a 39 mile trip in my truck to see my girl friend. Got most of the way there, got off at a busy off ramp with a stop light at the end of the ramp. Traffic was barely moving, as a result I had to use my clutch a lot at the friction point to creep with the traffic flow. got almost to the light and something weird happened, truck refused to go any more, pedal got really hard to push in, engine was still runnng fine, but it wouldn't go, had idiots lined up behind me, put on flashers but they didn't have the sense to go around, they missed like 2 green lights with me sitting there with left arm out the window trying to motion them around, I couldn't get off the road, because they were right up behind me on my bumper, and the only way Ranger was moving was by gravity back down that hill....

Anyhow, finally got them out from behind me, coasted it off the road, someone offered me a ride, got to a pay phone, called Geico towing service. Then took life in hands to walk back to truck. Finally made it back. Managed to push the clutch in far enough to start engine, pumped the pedal several times, this is a hydralic system by the way, just bled it a week or so ago, then it made a weired clunking noise and went in a little further, then it got easy to operate and felt normal again, I put it in gear and got the heck out of there, stopped at a payphone, called and cancelled the tow call.

What do you guys think??? Puzzled unless the clutch did stick to the pressure plate, if this is the case, is my clutch plate in need of replacement? I have almost 75K on the truck, bought it new, original clutch.
 

·
Premium Member
Joined
·
26,052 Posts
if its hydrolic it may be the problem but usually when the pressure is low from no fluid the petal is soft and wont come up just flops around.
 

·
Registered
Joined
·
1,552 Posts
Discussion Starter #3
The hydraulic fluid is full though, first thing I checked. Actually its just brake fluid.
 

·
Premium Member
Joined
·
26,052 Posts
well then you can look at the mechanism its self and rule out part by part, is it the cable? could be, is it the fork arm possibly miss aligned = hard ot push in? is it the pressure plate its self perhaps, could be the throw out bearing but i doubt that.
 

·
Registered
Joined
·
1,552 Posts
Discussion Starter #5
Thing is, after it made that noise its operating correctly, so it makes it sort of hard to use the process of elimination to find the malfuncion, because right now there isn't one???
 

·
Registered
Joined
·
1,552 Posts
Discussion Starter #6
Nobody else has any ideas on this one?
 
1 - 6 of 6 Posts
Top