Mustang Evolution Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1
Hey guys, I have a high pitched whistle while I'm on the accelerator coming from what sounds like the cai. I first thought it was because of my maf not lining up with the cai properly but I taped it off really well n saw no improvement. Today when I was checking out my throttle body I noticed a lil piece on my cold air intake and it looks like it was put on to plug a hole. How I didn't notice this before is beyond me but if anyone could tell me if this I factory or was added on my car and could b making the noise it would b a big help thanks

image-190718954.jpg
 

·
Premium Member
Joined
·
8,133 Posts
That's how mine is as well. I believe you have to plug it in because there is no other connection that would go in there
 

·
Registered
Joined
·
293 Posts
Most CAI's make high pitch "whistle"... if your car still runs great, and if you installed it correctly... then you are just hearing the CAI doing it's job, and there's nothing to worry about.
 

·
Registered
Joined
·
1,001 Posts
One of the OEM CAI's design functions--it is a CAI, and a pretty good one at that; good enough to get me to 262/305 rwHP/lb-ft with a lousy paper filter--is to minimise intake noise. Aftermarket intakes are no so constrained so you get to hear the raw intake noise...
 

·
Registered
Joined
·
7,311 Posts
that hole is for a temp sensor...earlier model GTs have them whereas later model new edges have them built into the maf so the hole gets plugged.
 
1 - 5 of 5 Posts
Top