Mustang Evolution Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
3,690 Posts
Your car came with a CAI.
 

·
Registered
Joined
·
92 Posts
Your car came with a CAI.
Ditto...

Don't make the same mistake I did... TWICE! First CAI I had was an Airaid(no tune required). It did feel like it added some umph above 4k rpm's, but throttle response felt sluggish. Just installed a Steeda CAI with a custom dyno tune, but the idle surges like crazy! WOT with it is insane! ... the shop attempted to correct the surging, but it's still occurring... less than before, though.

Do yourself a favor and keep the stock air box. It flows well enough. Get a good tune.
 

·
Registered
Joined
·
3,547 Posts
Ditto...

Don't make the same mistake I did... TWICE! First CAI I had was an Airaid(no tune required). It did feel like it added some umph above 4k rpm's, but throttle response felt sluggish. Just installed a Steeda CAI with a custom dyno tune, but the idle surges like crazy! WOT with it is insane! ... the shop attempted to correct the surging, but it's still occurring... less than before, though.

Do yourself a favor and keep the stock air box. It flows well enough. Get a good tune.
No one else with the steeda cai gets surges. You need a better tuner... Or did you maybe buy the wrong CAI as their is one for manuals and one for auto.
 

·
Registered
Joined
·
92 Posts
No one else with the steeda cai gets surges. You need a better tuner... Or did you maybe buy the wrong CAI as their is one for manuals and one for auto.
Correct CAI(manual)... checked for leaks, KAM reset, cleaned both MAF Sensor and Throttle Body, and no DTC's. Tuner is well known by a few out there(Steeda and Co., AED, etc.) and believe he can get it running right. A quick Google search will show that I'm not the only one. A few out there had issues to tune for JLT's CAI. Could it be the tune? Maybe. Could it be something else? Perhaps, but this issue popped up right after CAI install and tune. I'm going to monitor this for a few weeks to see if it sorts itself out.
 

·
Registered
Joined
·
3,690 Posts
Your car came with rims, tires, and an axle back exhaust.
The topic we're talking about is a CAI which our cars come with from the factory and are hard pressed to be improved on. But your sarcasm is duly noted.
 

·
Banned
Joined
·
1,681 Posts
Correct CAI(manual)... checked for leaks, KAM reset, cleaned both MAF Sensor and Throttle Body, and no DTC's. Tuner is well known by a few out there(Steeda and Co., AED, etc.) and believe he can get it running right. A quick Google search will show that I'm not the only one. A few out there had issues to tune for JLT's CAI. Could it be the tune? Maybe. Could it be something else? Perhaps, but this issue popped up right after CAI install and tune. I'm going to monitor this for a few weeks to see if it sorts itself out.
Hmm. No one with a steeda tune has that problem. I can tell you that it's your tune for sure.
 

·
Registered
Joined
·
102 Posts
just installed the BBK cai and bama 93r tune. car is a different animal. if i gradually accelerate in 3rd gear and then smash it at like 5k rpm car breaks lose and i go into 4th and then smash it and it just puts you back. with all my current stuff i bet my car could run a 12.3 if i knew how to launch that is haha.
 

·
Registered
Joined
·
1,151 Posts
GrayGhost,

If you don't mind ... can you send me your info to [email protected] and let us take a look at your tune?

Will need the processor code, serial number off the tuning device, fuel octane and modifications.

I spoke with Gus and he believes he knows what the issue is ... I can tell you it's not the CAI causing the issue.

I look forward to hearing from you and helping you out with your tune trouble.

Best Regards,

TJ
 

·
Registered
Joined
·
3 Posts
Was this issue resolved and what was the cause. I've got a bad surge on initial start up after the cars sat over night.
 

·
Registered
Joined
·
3 Posts
Im actually on a Lund tune and they been telling me it's the cold air intakes fault for the surge.

I don't know if the op of this threads surge was on cold start like mine, but that's the only time it happens for me, and it's pretty bad sometimes.
 
1 - 20 of 21 Posts
Top