Mustang Evolution Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
340 Posts
Discussion Starter #1
Anyone know what I can look into to fixing this? Started out with not getting one station some and now I cant get anything but static most of the time. All the other cars get reception so its not location. I use my phone most of the time but still want a working radio. Im out of my bumper to bumper so looking to fix it myself most likely

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
 

·
Registered
Joined
·
274 Posts
I would say make sure that your antenna didn't wiggle out.

Sent from my SM-G935V using Mustang Evolution mobile app
 

·
Registered
Joined
·
340 Posts
Discussion Starter #4
12, base. Ill have to find time to look into if anything is loose. Was just seeing if was any weird things to look for and not just straight forward, with my luck it would be some 1 in a million occurrence

Sent from my SAMSUNG-SM-G920A using Mustang Evolution mobile app
 

·
Registered
Joined
·
274 Posts
I have an 11 base which is basically the same car. I would check the antenna in the dash to make sure it's still connected to the head unit. Possibly also unscrew your exterior antenna and clean both the antenna and where it screws in.

Sent from my SM-G935V using Mustang Evolution mobile app
 

·
Registered
Joined
·
190 Posts
I have an 11 base which is basically the same car. I would check the antenna in the dash to make sure it's still connected to the head unit. Possibly also unscrew your exterior antenna and clean both the antenna and where it screws in.

Sent from my SM-G935V using Mustang Evolution mobile app

The antennae is in the dash ?? I get zero reception also .


Sent from my iPhone using Mustang Evolution
 

·
Admin
Joined
·
5,822 Posts
Did you, or a previous owner replace the radio antenna with an aftermarket "stubby" one?
 

·
Registered
Joined
·
274 Posts
The antennae is in the dash ?? I get zero reception also .


Sent from my iPhone using Mustang Evolution
The antenna that is hooked into the bag of your radio. There is a plug that the wire for your outside antenna plugs into. Every car has one, if the antenna comes unplugged or is loose the head unit is not receiving a signal so it'll be all static.

Sent from my SM-G935V using Mustang Evolution mobile app
 

·
Registered
Joined
·
190 Posts
The antenna that is hooked into the bag of your radio. There is a plug that the wire for your outside antenna plugs into. Every car has one, if the antenna comes unplugged or is loose the head unit is not receiving a signal so it'll be all static.

Sent from my SM-G935V using Mustang Evolution mobile app

Ahh I see , that is highly likely to be my problem , thanks !


Sent from my iPhone using Mustang Evolution
 

·
Registered
Joined
·
753 Posts
My radio reception sucks and always has since it was new. The fix it to live closer to the city lol where the radio stations or repeaters are.


Sent from my iPhone using Mustang Evolution
 

·
Registered
Joined
·
29 Posts
I don't think there's much consideration for radio entertainment with the advent of MP3, iPod, flash drive, CD music and satellite radio. I use three 16GB flash drives, a 38GB iPod and a few antique CD's. Don't have much need for AM/FM radio reception.
 

·
Registered
Joined
·
274 Posts
I don't think there's much consideration for radio entertainment with the advent of MP3, iPod, flash drive, CD music and satellite radio. I use three 16GB flash drives, a 38GB iPod and a few antique CD's. Don't have much need for AM/FM radio reception.
I don't even use AUX anymore. I added a GROM audio unit which gives my Base 2011 Bluetooth by using the SAT. Everything comes through my phone now.

Sent from my SM-G935V using Mustang Evolution mobile app
 
1 - 14 of 14 Posts
Top