Mustang Evolution Forum banner
1 - 8 of 8 Posts

·
Premium Member
Joined
·
8,080 Posts
Discussion Starter · #1 ·
Hey guys so a couple days ago my cel came on while I went over a bumper hard and scraped my exhaust, I believ I tore out one of my o2 sensors. Haven't had time to check it out but will do so later today. But then a day later while my car is going over 40 mph my car starts shaking and the steering wheel as well. What could cause this? My friend said wheel balance. Anything under 40 and it's fine but when over 40 it shakes and vibrates. Thanks for any input
 

·
Registered
Joined
·
1,001 Posts
Bent wheel or you damaged some other front suspension component...
 

·
Registered
Joined
·
1,001 Posts
Hmm ima look into that today. But wheels aren't bent
You can't know that until you jack up the car and check the run out with a dial indicator--as little as 0.005" run out will make them shake. It could be a damaged tire (broken belt) also, depends on how hard you hit the bump...
 

·
Premium Member
Joined
·
8,080 Posts
Discussion Starter · #5 ·
You can't know that until you jack up the car and check the run out with a dial indicator--as little as 0.005" run out will make them shake. It could be a damaged tire (broken belt) also, depends on how hard you hit the bump...
I will jack it up today and see if I can see something wrong. It sounded bad but haven't had time to check. Will do so today, thanks cliffy for the info
 

·
Premium Member
Joined
·
8,080 Posts
Discussion Starter · #6 ·
So I cheked the code and it's p0174 which is lean bank 2 and it's most likely my o2 lol. The shaking is that I dropped my car recently and haven't gotten it aligned so ima go ahead and do that today
 

·
Registered
Joined
·
1,001 Posts
So I cheked the code and it's p0174 which is lean bank 2 and it's most likely my o2 lol. The shaking is that I dropped my car recently and haven't gotten it aligned so ima go ahead and do that today
This would have been useful information in your first message...
 

·
Premium Member
Joined
·
8,080 Posts
Discussion Starter · #8 ·
I thought it would of been because of the bump that scrape, because before It wouldn't shake. I've been driving it without being aligned and it hasn't shook before. So I thought that's what caused it
 
1 - 8 of 8 Posts
Top