Mustang Evolution Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter #1
Ok so i get the wonderfull check engine light. I take it to autozone and get "EGR flow insufficent."

The dude resets the code and the light goes off.

about an hour or 2 later i am at a red light, i pull off a little low on rpms and the car sputters and the light comes back on.

The car drives fine with the exception of that little sputter its getting when i try to pull off at low rpms.

i have CAI and dual exhaust 2.25" X pipe. Any suggustions?

Do you think it is safe for me to take the car on a road trip to NC this weekend?
 

·
Registered
Joined
·
567 Posts
1) perfectly safe. why wouldnt it be.

2) when you have free time, take off you regr and clean it out with some carb cleaner. It has exhaust fumes flowing through it afterall and can get nasty in there, sometimes clog up.
 

·
Registered
Joined
·
151 Posts
Discussion Starter #3
alright. I thought that it wasnt a big deal. thanks though.

My dad said the same thing hehe.

amazing how smart dads can be :)
 

·
Registered
Joined
·
33 Posts
mikael said:
If I remember right sometimes this has to do with the actual sensor that checks flow. The DPFE or something? Sorry for being so vague.

There's a Ford TSB on this. They extended the warranty on this part past the normal 36k. A dealer SHOULD replace it for free, depending on how many miles are on the car.
 

·
Registered
Joined
·
7 Posts
ericstanley said:
mikael said:
If I remember right sometimes this has to do with the actual sensor that checks flow. The DPFE or something? Sorry for being so vague.

There's a Ford TSB on this. They extended the warranty on this part past the normal 36k. A dealer SHOULD replace it for free, depending on how many miles are on the car.
its the DPFE sensor. he should have got an extended warranty in the mail or something for that part specifically. i dealt with that damn code this past summer. :oops:
 
1 - 6 of 6 Posts
Top