Mustang Evolution Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
Hey folks, it's been a while. I have a possible dumb question. Here it goes: Do the 2005-2010 GT have an EGR valve? If so, do any of you know where is located? One more question. Do any of you experience any pinging during hard acceleration? Did you find the culprit? I need help here.

Thanks for your help.
 

·
Registered
Joined
·
8,325 Posts
The 05-10 Mustang GT's do not have a EGR valve.

How long has it been since your car has had any maintenance done to it? Like changing the fuel filter, for instance?
 

·
Registered
Joined
·
8,325 Posts
It could also be caused by some carbon deposits in the combustion chambers... The same carbon that accumulates around the spark plugs and causes them to get stuck and break off during removal.

How old are the spark plugs?
 

·
Registered
Joined
·
100 Posts
Discussion Starter #6
I did change the spark plugs and it was little carbon on them. I ran 91octane Shell for a long while after that to no avail. I just this past weekend ran Sea Foam through the throtle body. Since is more noticeable when it's warm.. is there a possibility of a bad knock sensor? Thanks for your responses.
 

·
Registered
Joined
·
8,325 Posts
You should definitely clean/inspect your MAF sensor, particularly if it has never been done.
And make sure to disconnect the negative battery cable before removing and cleaning it.

In the absence of a diagnostic trouble code, all of the "tune up" items should be looked at first.

And just to clarify, this car is stock, correct?
No tune, or any other engine modifications?
 

·
Registered
Joined
·
100 Posts
Discussion Starter #11
I bought the car use approx. 6 yrs ago and it always had this issue. I drives perfectly at normal speed. I can gradually increase speed with no problems whatsoever. It's only when I punch it. It may have been tuned before I bought it, how do I check that? I know some of these 4.6s are a pain in the ***. As far as I know it's all stock. No CAI or anything. I wll clean the MAF and see what happens. I have done the tune-up stuff and the issue stayed the same. I bought it with 46k miles on and it now has 87K. I never have cleaned the MAF. Thanks again.
 
1 - 11 of 11 Posts
Top