Mustang Evolution Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
350 Posts
Discussion Starter · #1 · (Edited)
Took the car for a drive today and could tell that the exhaust note wasn't as loud compared to last time I drove it. I have a American Thunder muffler. Also, when I rev, it starts popping. Never did this until now. When I start to get on it there is little to no drone. I used to have a bit of drone and now there is nothing. I don't understand how the exhaust note can change all of a sudden. Has anyone else experienced this? Any thoughts on how to fix it?
 

·
Registered
Joined
·
350 Posts
Discussion Starter · #5 ·
Maybe you just broke it in
Well it only made popping noises till I broke it in. I've had it for a little but over a year So I don't think it would have taken that long to break it in =\
 

·
Registered
Joined
·
2,201 Posts
Well it only made popping noises till I broke it in. I've had it for a little but over a year So I don't think it would have taken that long to break it in =\
Happened to me..get underneath, one of my clamps came loose, causing a pretty bad leak..I fixed it myself but I couldn't get it aligned correctly for the life of me, brought it to a meineke and they charge me 30$ go change the clamp, tighten everything, and re align it..noticed the difference as soon as I pulled out of there
 

·
Registered
Joined
·
350 Posts
Discussion Starter · #7 ·
Happened to me..get underneath, one of my clamps came loose, causing a pretty bad leak..I fixed it myself but I couldn't get it aligned correctly for the life of me, brought it to a meineke and they charge me 30$ go change the clamp, tighten everything, and re align it..noticed the difference as soon as I pulled out of there
The thing about that is wouldnt the leak make it louder? mine got quieter and thats whats stumping me
 

·
Registered
Joined
·
350 Posts
Discussion Starter · #8 ·
Problem solved. Thanks for everyone's input!
 

·
Registered
Joined
·
2,201 Posts
The thing about that is wouldnt the leak make it louder? mine got quieter and thats whats stumping me
Actually no, I have LM1s and everyone knows that defined slp sound..well when it came disconnected it was sti loud, just had no definition in the sound, if that makes sense

---------- Post added at 08:47 AM ---------- Previous post was at 08:46 AM ----------

Problem solved. Thanks for everyone's input!
What was it?
 

·
Registered
Joined
·
350 Posts
Discussion Starter · #10 ·
Actually no, I have LM1s and everyone knows that defined slp sound..well when it came disconnected it was sti loud, just had no definition in the sound, if that makes sense

---------- Post added at 08:47 AM ---------- Previous post was at 08:46 AM ----------



What was it?
Cold air.
 
1 - 12 of 12 Posts
Top