Mustang Evolution Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,895 Posts
Discussion Starter #1
I forgot i have fords factory amp in my 95 under the stock head unit.

If i plug in a new deck, and wire in amplifiers and woofers will everything be ok?
 

·
Premium Member
Joined
·
897 Posts
I didnt have a facotry amp in my 95...if there was I took everytrhing out lol
 

·
Premium Member
Joined
·
897 Posts
I didnt have the Mach i had the premium audio package, and there was no amp
 

·
Registered
Joined
·
1,895 Posts
Discussion Starter #5
how much power are these things rated for, i saw a page on them before, i believe it was 60w. But i cant find that page anymore.
I just dont want ti to burn out the headdeck or anything.

Its wired right into the head units harness........
 

·
Premium Member
Joined
·
897 Posts
well you wont need it the new headunit will power speakers take it out, and hook in the HU, if the Wire Harness doesnt match like mine did, there is a 2nd set bolted to the fram behind the dash for radio too....I had to use the other set to do mine, but all my speakers are wired to my amp which was a *****
 

·
Premium Member
Joined
·
19,890 Posts
Are you wanting to just amp your subs? If that's all you're wanting to do, go to any competent car audio place and get a wiring harness specific for you setup. Then get some tap in clamps you just clamp to your speaker wires that will give you outs for your sub. You won't even be messing with the factory amp at all. Once you've done this, connect the rca plugs to the end of the wires you clamped in and run directly to the amp. Something else you'll have to do is find the "remote" wire running to your head unit. This should be labeled on any aftermarket unit....actually, come to think of it, any aftermarket unit should have pre-amp outs on it already. :oops: Wasn't thinking when i started this and i'm too lazy to delete it. Ok, ignore me, I'm officially out of it now. So i just wrote a whole bunch of bs...
 
1 - 9 of 9 Posts
Top