Mustang Evolution Forum banner
1 - 20 of 27 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter · #1 ·
I have a 2003 v6 stang and i self put in some factory lights, but after 3 months they just wont turn on. I have checked the bulbs and bought new bulbs and still wont turn on. What is the problem to this?
 

·
Registered
Joined
·
246 Posts
What kind of wiring harness are you using?
 

·
Premium Member
Joined
·
19,783 Posts
Wally world carries fuses. Just find the fuse in your wiring and pull it out, carry it into a parts store and they'll help you find it. Post some pics sometime...lol. I love them oxford whites
 

·
Premium Member
Joined
·
19,783 Posts
Looks an awful lot like mine lol.
Someone needs a grill delete and rims...
 

·
Premium Member
Joined
·
19,783 Posts
Mjcorn23 said:
That is like the pot calling the kettle black
All in good time...I have stuff on the way now...just trying to get it all in slowly...
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #13 ·
lowflyn said:
Looks an awful lot like mine lol.
Someone needs a grill delete and rims...
haha...... I know..... I cant afford rims right now but, by the mid of summer i'll get rims, a 1.5 drop, and dual exhaust :D
 

·
Premium Member
Joined
·
19,783 Posts
I have the dual exhaust so far...riding on 4 bald tires right now so I'm trying to find some good rims and tires lol. Just ordered my gt fog lights, so I'm getting started slowly lol
 

·
Premium Member
Joined
·
2,495 Posts
if its not your fuse its likely your switch, we rarely get mustangs in the shop, but when they come in its either for noisy windows, clashing transmissions (manuals) or fog lights inop - and 9 times out of 10 its the switch causing the problem
 

·
Premium Member
Joined
·
19,783 Posts
That'll do it everytime..now get her replaced...
 

·
Premium Member
Joined
·
25,803 Posts
you can test the wires by using a little power tester to see if they wires are hot, which i bet you are not.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #20 ·
ooooooooooooooh yeah something got hot. lol check this out. What could of caused this? Could it be the bulbs requiring too much power?
 

Attachments

1 - 20 of 27 Posts
Top