Mustang Evolution Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
106 Posts
Discussion Starter #1
I was changing my fuel filter and the tip of the hose with the clamps broke off :(
 

·
Banned
Joined
·
8,779 Posts
There are different style clamps for fuel injection, standard clamps won't work because they are not designed to hold the pressure developed in EFI systems.

As long as the fitting you are clamping onto has the ridge around it and you use the correct EFI clamps it should be ok.
 

·
Banned
Joined
·
8,779 Posts
Too late lol
Not yet.

1. Leak
2. Fire
3. Car Gone
4. Possible injury or death.

Then it's too late.
Your car, your life, your choice.
 

·
Registered
Joined
·
106 Posts
Discussion Starter #8
I tried it before I saw the reply yeah its just too much presure. How much would I have to replace I didn't look .

ForumRunner_20111118_163307.png
 

·
Banned
Joined
·
8,779 Posts

·
Banned
Joined
·
8,779 Posts
I guess its more serious than I thought :'(

If you are planning on forced induction, high HP mods, now might be the time to look at an aftermarket fuel system.
 

·
Registered
Joined
·
106 Posts
Discussion Starter #13
I do but not now first a stroker or 351 and tranny hopefully this year with taxes

---------- Post added at 05:15 PM ---------- Previous post was at 05:08 PM ----------

Well I just bought the connecter from autozone :)
 

·
Registered
Joined
·
106 Posts
Discussion Starter #16
Yea I just gotta wait till Monday I'm heating it but I can't get it right and once it bends like that its done :(
 

·
Banned
Joined
·
8,779 Posts
Yea I just gotta wait till Monday I'm heating it but I can't get it right and once it bends like that its done :(
If you fill the hose with sand, pack it in there and block off the ends with tape or something, then heat and bend it, it should hold its shape.
Just be sure to rinse and blow out all of the sand.
 

·
Registered
Joined
·
106 Posts
Discussion Starter #19
Finally had time to fix it . I finally got it running the filter was so dirty that was the reason of my rough idle and loss of power. My pony was starving lol
 

·
Banned
Joined
·
8,779 Posts
Finally had time to fix it . I finally got it running the filter was so dirty that was the reason of my rough idle and loss of power. My pony was starving lol
Yep, like trying to drink a large soda through a spray can nozzle extension. ;)
 
1 - 20 of 21 Posts
Top