Mustang Evolution Forum banner
1 - 20 of 57 Posts

·
Premium Member
Joined
·
4,828 Posts
Discussion Starter · #1 ·
Well I had a 30 min phone conversation with Pete at Fordchip tonight. He is saying I will be at 190 RWHP he said maybe 200 so I will kweep my fingers crossed. He did say if I had a 5 speed it woud be at or around 220RWHP. But he said that is not bad considering stock 5.0 mustangs dyno all day at 175 -180 RWHP. So I am optimistic.

Corey
 

·
Registered
Joined
·
1,444 Posts
Get that aluminum driveshaft next Corey, did Pete know about your fancy transmission?
 

·
Premium Member
Joined
·
4,828 Posts
Discussion Starter · #7 ·
Yes Pete knows everything. The Tranny will only really help in track times and means little on the dyno. His opinion on what I am going to dyno at is based on experiences with many cars with near Identical mods. Damn Tranny is going to keep me from hitting 200-220 rwhp :oops: :oops: :oops: :oops: :oops:

Corey
 

·
Registered
Joined
·
1,444 Posts
Guess we will just have to wait and see, would be great if you fooled him and got more than he thinks you will. :p
 

·
Registered
Joined
·
31 Posts
Corey,
That guy is clueless if he thinks that an manual is worth 20-30 ponies over an auto. SSM has dyno runs that show it to be worth 9 ponies on their stage 2 setup and 5 tq. Mags have also posted numbers that are closer.
 

·
Registered
Joined
·
1,444 Posts
215 rwhp, how close am I now Corey? lol.
 

·
Premium Member
Joined
·
4,828 Posts
Discussion Starter · #15 ·
Well guys I must say from the start I was VERY VERY DISAPPOINTED . The highest numbers were

139 hp

190 tq :shock: :shock: :shock: :( :( :( :( :x :x :x :x :x :oops: :oops:

Bit I have a few problems he is a full tuning shop(but not for fuel injected yet for another 30 days) So we found the plugs I have for nitrous suck and I had a bad one original numbers were 134.7 hp changed the one plug and got to 139hp.

The next problem is air/ fuel I am running way to rich here are the numbers

The fuel air ratio this is killing me We did compression checks and vacume checks and they were all good.

The power is there but the fuel problem has to be delt with. Damn that means getting a reburn from Fordchip and that will take a millennium to get back :oops: :oops: :oops: :oops: :oops: :oops: :oops:

Corey
 

·
Registered
Joined
·
31 Posts
Nitrous plugs should be too cold for an N/A motor. Use the Copper plus and round the front of the side electrode and set it so that it covers only 1/5th to 1/3 of the center.
 
1 - 20 of 57 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top