Mustang Evolution Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
730 Posts
Discussion Starter · #1 ·
I notice that when pass 4000rpm on hard acceleration it feels like it bogs ever so slightly. At first I thought it was the advance trac so I disabled it but sometimes it still happens? Another way I could describe it is it almost feels like the wheels spin for a fraction of a second. Could a glazed or slipping clutch cause this? It's a 2013 with 9000km on it. Any input appreciated.
 

·
Registered
Joined
·
730 Posts
Discussion Starter · #3 ·
Not really bad at all. But I do notice it. I called my Ford dealer and they where like, huh? It does what exactly? Lol. It's my first manual so I have no idea if its common or not.
 

·
Registered
Joined
·
2,280 Posts
It could be clutch slip, ford dealerships are useless you can get more knowledge from people off of here. Its actually a common problem in the mt82s it could be the shift fork... I would have to ride in it to see
 

·
Registered
Joined
·
730 Posts
Discussion Starter · #5 ·
It could be clutch slip, ford dealerships are useless you can get more knowledge from people off of here. Its actually a common problem in the mt82s it could be the shift fork... I would have to ride in it to see
Yeah that's y I posted it. Lol, they will be like, we drove it and everything is fine, your crazy now go home. Lol

---------- Post added at 11:49 PM ---------- Previous post was at 11:44 PM ----------

It could be clutch slip, ford dealerships are useless you can get more knowledge from people off of here. Its actually a common problem in the mt82s it could be the shift fork... I would have to ride in it to see
Shift fork? Is that bad.lol.
 

·
Registered
Joined
·
730 Posts
Discussion Starter · #7 ·
Yea they hate modified cars too, can't expect anything from them. But your problem sounds like it could be clutch slip. Is it in every gear?
I don't think so but I don't get the chance to push third and up to often. If it was clutch slip is there anything they/I could do without replacing it? From what I can tell it doesn't happen all the time and its only in the higher rpm range. Thx for your help. : )
 

·
Registered
Joined
·
2,280 Posts
Not really because it could be a multitude of things. Bad clutch pads, bad shift fork, or the plate that holds it could be bad. Or maybe its fine and just breaking in could be a multitude of things. Let me know what you do or if you need anything else
 

·
Registered
Joined
·
1,623 Posts
Clutch slip? If so, it should be in every gear if he floors it. That would be an apparent problem. Unless he's abused it, it shouldn't be an issue. Clutch fork has to do with shifting into and changing a gear, no idea how that could affect it... You shouldn't have a slipping or glazed clutch at your mileage unless you've been riding the clutch pedal and smelling clutch material.

This sounds really weird, but do this... go under the hood, pop open the fuse box. Remove fuse #47 for around 10min, pop it back in and take it for a ride. Let me know if the car feels perkier or not.
 

·
Registered
Joined
·
1,623 Posts
I'd love to blame it on a slipping clutch, believe me. It just doesn't seem likely.

Bogging at the start of first with 2.73s is a very common issue. You either have to slip the clutch like hell, get steeper gears, or accept it. In that vid, I noticed a weird pause near the top of 2nd gear, but that's all I could tell right off.
 

·
Premium Member
Joined
·
14,462 Posts
I'd love to blame it on a slipping clutch, believe me. It just doesn't seem likely.

Bogging at the start of first with 2.73s is a very common issue. You either have to slip the clutch like hell, get steeper gears, or accept it. In that vid, I noticed a weird pause near the top of 2nd gear, but that's all I could tell right off.
I definetly noticed it on the top end, and it matches with what OP was saying about it bogging at over 4k, i don't think its the clutch slipping. I honestly have no idea what the problem is.
 

·
Registered
Joined
·
730 Posts
Discussion Starter · #16 ·
Clutch slip? If so, it should be in every gear if he floors it. That would be an apparent problem. Unless he's abused it, it shouldn't be an issue. Clutch fork has to do with shifting into and changing a gear, no idea how that could affect it... You shouldn't have a slipping or glazed clutch at your mileage unless you've been riding the clutch pedal and smelling clutch material.

This sounds really weird, but do this... go under the hood, pop open the fuse box. Remove fuse #47 for around 10min, pop it back in and take it for a ride. Let me know if the car feels perkier or not.
Thanks for the help. I did learn how to drive stick on it that's why I thought maybe I glazed it. Once I down shifter from third to second and didn't rev match and the car shot me forward a did a little chirping of the rear tires when I was learning but other than that I'm very good to her.what will pulling the fuse out do? I've got the day off and I'm gonna go do that in 10. Thx guys.
 

·
Registered
Joined
·
3,986 Posts
Not a slipping clutch at all

If the clutch was slipping you sure won't get a bog, The engine would rev up extremely fast all the way up to the limiter. I can't tell you what is causing your bog but I can assure you it ain't a slipping clutch.

Ronnie
 

·
Registered
Joined
·
730 Posts
Discussion Starter · #18 ·
I definetly noticed it on the top end, and it matches with what OP was saying about it bogging at over 4k, i don't think its the clutch slipping. I honestly have no idea what the problem is.
I checked out your and its not the same thing. I'm not even sure if I did a vid while driving that anyone would even pick up on it. It might just be a drivers feel. Thx.

---------- Post added at 08:46 AM ---------- Previous post was at 08:43 AM ----------

If the clutch was slipping you sure won't get a bog, The engine would rev up extremely fast all the way up to the limiter. I can't tell you what is causing your bog but I can assure you it ain't a slipping clutch.

Ronnie
That's a relief, it definitely doesn't do that, whew, maybe its more of a software thing? I'm gonna try the fuse but it decided to f in snow today and I don't have my snow tires on. : ( Thx Ronnie.
 

·
Registered
Joined
·
3,986 Posts
MrMike

What mod's did you do to your car such as CAI, Mufflers, Tune, ???

Ronnie
 

·
Registered
Joined
·
371 Posts
My transmission was replaced due to bad synchros and faulty forks on all gears I never had a bog or anything except maybe in first but that should be due to the gears. Maybe type of gas? Lol idk
 
1 - 20 of 26 Posts
Top