Mustang Evolution Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
847 Posts
Discussion Starter · #1 ·
My a/c started making an onandoff clicking sound and eventually stopped blowin cold (refridgerant is full), i ignored it as summer was almost over. Now when running heat or defrost gettn the same click. Heater is working but motor keeps making that clickon clickoff sound and it changes the idle. Anyone know what this mite b??
 

·
Registered
Joined
·
1,120 Posts
My a/c started making an onandoff clicking sound and eventually stopped blowin cold (refridgerant is full), i ignored it as summer was almost over. Now when running heat or defrost gettn the same click. Heater is working but motor keeps making that clickon clickoff sound and it changes the idle. Anyone know what this mite b??
It might not be it but its worth a shot because my ac stopped blowing cold, it was my CCRM. It's located in the passenger side fender well. Take the wheel off and splash fender and it up by where the intake tube comes into the fender
 

·
Registered
Joined
·
847 Posts
Discussion Starter · #3 ·
Yup fan clutch relay is on the CCRM so I think you maybe on to something thanks bro

---------- Post added at 07:43 PM ---------- Previous post was at 07:42 PM ----------

Yup a/c clutch relay is on the CCRM and I'm pretty sure that's the clicking sound, so I think you maybe correct thanks bro
 

·
Registered
Joined
·
1,120 Posts
Yup fan clutch relay is on the CCRM so I think you maybe on to something thanks bro

---------- Post added at 07:43 PM ---------- Previous post was at 07:42 PM ----------

Yup a/c clutch relay is on the CCRM and I'm pretty sure that's the clicking sound, so I think you maybe correct thanks bro
Anytime at all bro!! Always glad to help out
 
1 - 4 of 4 Posts
Top