Mustang Evolution Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1
Cleaned my maf and throttle body today. Completely removed tb to clean it when I put everything together and restarted my car my idle was all over the place. At first it was like a chugging or throbbing sound. I turned it off and disconnected my battery. Waited a few mins and reconnected and started the car and turned on all my accessories. The car is now idling extremely high. Around 2000+ rpm and really wants to pull even when I'm pressing on the brake. Someone pls help me get it back to normal!!!!

---------- Post added at 05:56 PM ---------- Previous post was at 05:54 PM ----------

I know about the threaded rod to reset base idle but I'm not sure what to do with it or how to change it. Does anyone have any info?
 

·
Registered
Joined
·
1,224 Posts
Sounds like your tps or throttle position sensor isn't functioning right. Did you take it off when you cleaned everything. If you hooked it back up wrong it can do that. Also sometimes when removing the tps it can be ruined in the process. Happened to me when I put a new throttle on my car.
 

·
Registered
Joined
·
148 Posts
Discussion Starter #4
Lol ya don't mind me I forgot the plug on the back of the tb haha wow I'm gunna blame the dark and rainy conditions. Yikes thanks tho guys

---------- Post added at 06:24 PM ---------- Previous post was at 06:23 PM ----------

I also snapped my throttle body where one of the screws goes in. Whatta day. I hope that won't cause any problems it seems really stable.

---------- Post added at 06:25 PM ---------- Previous post was at 06:24 PM ----------

The front right bolt* didn't line up when replacing and over tightened it I guess. Everything else was flush and went back easily. Really weird
 

·
Registered
Joined
·
2,201 Posts
d_1212 said:
Lol ya don't mind me I forgot the plug on the back of the tb haha wow I'm gunna blame the dark and rainy conditions. Yikes thanks tho guys

---------- Post added at 06:24 PM ---------- Previous post was at 06:23 PM ----------

I also snapped my throttle body where one of the screws goes in. Whatta day. I hope that won't cause any problems it seems really stable.

---------- Post added at 06:25 PM ---------- Previous post was at 06:24 PM ----------

The front right bolt* didn't line up when replacing and over tightened it I guess. Everything else was flush and went back easily. Really weird
Lol I cleaned my maf a few months back, forgot to plug it back in when I put it back together, the car drove like I was towing an f150 followed by the check engine light, only drove it 2 miles than pulled over when the light came on, i started freaking the f out and almost posted a quick help me thread on ME, popped my hood before i did so and slapped myself in the head when i saw the maf was disconnected lmao!
 

·
Registered
Joined
·
3,257 Posts
NJstanger said:
Lol I cleaned my maf a few months back, forgot to plug it back in when I put it back together, the car drove like I was towing an f150 followed by the check engine light, only drove it 2 miles than pulled over when the light came on, i started freaking the f out and almost posted a quick help me thread on ME, popped my hood before i did so and slapped myself in the head when i saw the maf was disconnected lmao!
I did a similar thing!.. Except I didn't even leave the drive way, mostly because I couldn't due to the fact it kept dying on me!.. Hahahahahaha. :/
 

·
Registered
Joined
·
7,311 Posts
did you clean your IAC while you were cleaning the MAF and TB...if not it's just two bolts and can really make a difference in how smooth it idles even though you got it back to where it needs to be. I clean all three about every 6 months
 

·
Registered
Joined
·
148 Posts
Discussion Starter #8
1slosix said:
did you clean your IAC while you were cleaning the MAF and TB...if not it's just two bolts and can really make a difference in how smooth it idles even though you got it back to where it needs to be. I clean all three about every 6 months
No I didn't, to b honest I'm kind of a newbie. Dnt know my way around an engine too well yet. Trying to learn as I go. Taking apart the tb was probably the biggest job I've done to date. I would def b interested in cleaning it if u could give some details and descriptions of the IAC. Cleaning the maf, tb, adding fuel injector cleaner, and seafoaming vacuum line and engine really woke up my car. It was like night and day. I was so impressed w the outcome.
 

·
It's not me, it's you.
Joined
·
6,752 Posts
You've got a good start. Just keep tinkering and staying up with the forum and you'll be a know-it-all gear head like most of these other bums here. Lol
 

·
Premium Member
Joined
·
6,120 Posts
primer2tone said:
You've got a good start. Just keep tinkering and staying up with the forum and you'll be a know-it-all gear head like most of these other bums here. Lol
^+1 hahaha

I don't make those mistakes anymore ;) I just maker bigger mistakes now. Keep with it dude!
 
1 - 10 of 10 Posts
Top