Mustang Evolution Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter · #1 ·
So i was driving home from work today and my mustang was driving what felt to be just fine, well i stopped at a light and waited for it to turn green. When it changed i went to go push my clutch in to put it in gear and i felt like the clutch pedal drastically changed. Everything about it. It catches so much quicker it feels like, the pedal feels softer, and so much shorter than before. Sounds odd and its hard to explain but im just wondering if anyone knows what might be going on or any tips

---------- Post added at 03:02 PM ---------- Previous post was at 03:00 PM ----------

Car has 104k miles, not sure if clutch ever replaced, makes kind of squeaking sound when letting clutch pedal out
 

·
Registered
Joined
·
79 Posts
So i was driving home from work today and my mustang was driving what felt to be just fine, well i stopped at a light and waited for it to turn green. When it changed i went to go push my clutch in to put it in gear and i felt like the clutch pedal drastically changed. Everything about it. It catches so much quicker it feels like, the pedal feels softer, and so much shorter than before. Sounds odd and its hard to explain but im just wondering if anyone knows what might be going on or any tips

---------- Post added at 03:02 PM ---------- Previous post was at 03:00 PM ----------

Car has 104k miles, not sure if clutch ever replaced, makes kind of squeaking sound when letting clutch pedal out
It could be a streatched cable..or u may just have to adjust the bolt on the cable..the bolt could of backed off causing that.I just had the same problem with mine last week and had to tighten the bolt on my clutch cable
 

·
Registered
Joined
·
68 Posts
If your cables in good condition check under the dash and make sure the quadrant isn't cracked there made of plastic. My 01 cracked and made my clutch feel funny.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #4 ·
Ill be sure to check it soon, but another question is its been really cold/snowy here lately and ive had to drive through a couple big puddles, so is there any possibility of maybe ice or something causing the problem too?
 

·
Registered
Joined
·
2,101 Posts
Ill be sure to check it soon, but another question is its been really cold/snowy here lately and ive had to drive through a couple big puddles, so is there any possibility of maybe ice or something causing the problem too?
No way..way to hot in that area for any ice
 
1 - 10 of 10 Posts
Top