Mustang Evolution Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
I'll be driving and when I clutch my rpms go up and it makes the car jump, but I don't think it's the clutch it's my accelerator Getting stuck or something because when I gun it it stays at that rpm for a second and then will idle at 2k....but then stop doing that randomly.....?
 

·
Registered
Joined
·
73 Posts
Discussion Starter #3
It feels like the throttle gets stuck for a second and does it every now and then. I have a lot of play in my as pedal maybe my cable is bad?
 

·
Registered
Joined
·
493 Posts
Possibly. You shouldn't have just a whole lot of play before the throttle engages. I would check any pinch points that it may be getting stuck at, how it is mounted on the engine, on the pedal, etc. A hung throttle could get you in a BAD situation...
 

·
Registered
Joined
·
915 Posts
My pedal assembly was causing that problem on mine, I just sprayed a little wd40 on it
 

·
Registered
Joined
·
73 Posts
Discussion Starter #6
91notchback said:
Possibly. You shouldn't have just a whole lot of play before the throttle engages. I would check any pinch points that it may be getting stuck at, how it is mounted on the engine, on the pedal, etc. A hung throttle could get you in a BAD situation...
I can lift the gas pedal up toward me that's what play I mean
 

·
Registered
Joined
·
493 Posts
I would take a look around and see if I could eliminate any pinch points, parts in need of lube, visibly broken parts, or mounting problems first. It's free so you might as well. If I was going to buy another cable, I would buy a Ford OE one.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #10
91notchback said:
I would take a look around and see if I could eliminate any pinch points, parts in need of lube, visibly broken parts, or mounting problems first. It's free so you might as well. If I was going to buy another cable, I would buy a Ford OE one.
Ok cool thanks a lot
 
1 - 12 of 12 Posts
Top