Mustang Evolution Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
I have a 2000gt only mods are pulleys and a cai. I washed it recently and gave the engine a spray to remove some of the dirt and grime and now engine sputters and dies when I hit the gas. The dial jumps to 6k but sounds like it stops at around 3k. When idling it holds at 700 for about 10 seconds then jumps to 1000 then back down to 700.
 

·
Registered
Joined
·
535 Posts
Did you wash the engine? Like with a pressure washer? And if you did, did you cover the electronics like coil packs, fuse box, etc. if you did you may have just loosened a connection. Check your spark plug cables at the coil packs by unplugging and re-plugging. Look at all the sensors and connections and make sure their plugged in and check the fuel injectors.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
All checked and all are secure. I unplugged and replugged just to be safe and I still have the issue. I can get it to drive but when I punch it in any gear it jerks hard.
 

·
Registered
Joined
·
98 Posts
Check and see if the wash accendentaly didn't disconnect any of the vacuum lines. Check by the idle control valve. Maybe one of the lines is getting air causing your mustang to drop the idle or even shut off.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
Don't know exactly what it was but I took care of the MAF. Put fuel injector cleaner in the gas and slapped some new plugs in her and she runs like a champ now.
 

·
Premium Member
Joined
·
1,499 Posts
yea could have been the spark plug just be careful when cleaning use a rag and cleaner
 

·
Registered
Joined
·
525 Posts
Don't know exactly what it was but I took care of the MAF. Put fuel injector cleaner in the gas and slapped some new plugs in her and she runs like a champ now.
When ever i spray the engine down,,i always take compressed air and dry everything off,,also coil over plugs are bad about catching water
 
1 - 15 of 15 Posts
Top