Mustang Evolution Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Went to crank my car this morning to go to class and it sounded like the battery was dead, no big deal but the tach and speedometer turned all the way to the right and hav stayed there. Tested battery and it's got a full charge, any ideas on what's wrong?
 

·
Registered
Joined
·
185 Posts
may be voltage regulator, may be alternator, disconnect clean and reconnect terminals, take car to advance, and have them run a free code reading and test the alternator charge while there at it.
 

·
Premium Member
Joined
·
6,120 Posts
Went to crank my car this morning to go to class and it sounded like the battery was dead, no big deal but the tach and speedometer turned all the way to the right and hav stayed there. Tested battery and it's got a full charge, any ideas on what's wrong?
If all connections are good, just go get a new battery. My brothers car had the same issue it would crank, crank, crank, crank, dddddddddddd crank whom!! Then some stupid **** started happening, took it to get tested full charge several times, he coughed it up bought a new battery. Almost talked him to buying a new SHO.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #13
But now at idle the rpms arents as stable and wen they dip down the car shakes??? Any ideas on what going on?
 

·
Registered
Joined
·
2,109 Posts
You reset the computer by replacing the battery but I would check for a simple vacuum leak around the egr valve or CAI if you have one. The egr has 3 plastic lines color coded, they get very brittle with time, not flexible.
 

·
Registered
Joined
·
2,109 Posts
All the vacuum lines start out together drivers side firewall, the egr is next to/behind the throttle body. I believe it has one line on top, three underneath, and one of those go directly into upper intake manifold. They are bundled up together until they get to egr, hope thats helpful somehow-
 
1 - 19 of 19 Posts
Top