Mustang Evolution Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
So I have a 95gt and I just put a ford racing cam e303 on it and swapped out the springs as well. Heads are stock as well as rockers and push rods... Well after we installed it it pretty much bent all the rods and broke a few rocker arms.. Replaced them and put new stock springs and worked good for a day and now I think it's screwing up again cause its making same knocking noise and you can tell its coming from heads please help cause I can't figure out what's going wrong
 

·
Registered
Joined
·
493 Posts
So I have a 95gt and I just put a ford racing cam e303 on it and swapped out the springs as well. Heads are stock as well as rockers and push rods... Well after we installed it it pretty much bent all the rods and broke a few rocker arms.. Replaced them and put new stock springs and worked good for a day and now I think it's screwing up again cause its making same knocking noise and you can tell its coming from heads please help cause I can't figure out what's going wrong
Rocker arms too tight and not enough lash?
 

·
Registered
Joined
·
860 Posts
Are your pushrods the correct length for that cam? Also pushrods and cams should be replaced together I believe. Did you remove valve lash correctly?

---------- Post added at 04:36 AM ---------- Previous post was at 04:35 AM ----------

Rocker arms too tight and not enough lash?
Same thought posted at the same time! :D
We'll it was until I edited!
 
1 - 3 of 3 Posts
Top