Mustang Evolution Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
941 Posts
Discussion Starter #1
i decided to get off my lazy ass and fix my n2o. looks like i have a leak. i used some sort of hardening something that looks like dried snot. it's been a long time and i honestly don't remember what i used.

my questions:

what eats away at glues so i can still use my leaking and gross fittings?

where can i find liquid teflon, i can't find it at lowe's or maybe it was home depot (i went to one but not both)?

my nitrous noid CLICKS, so it is receiving power and activating, but not spraying. i disconnected the bottom line and nothing comes out. however, i can purge just fine. wtf^^ mates?? maybe debris got in there? if so, is it ok to take the noid apart, or is there something i need to be careful about?

and who wants to give me their bottle heater? :p

and lastly, who wants sum'? :D
 

·
You want to **** me?
Joined
·
4,043 Posts
what kind of nitrous system do you have?? paint thinner might eat through that stuff... (is it silicon?) Id say somethings clogged in your jets. Is the fuel spraying or are they both cloggged?


edit: oh yeah, i want sum :p
 

·
You want to **** me?
Joined
·
4,043 Posts
well if the solenoid is clicking and no nitrous is coming through its gotta either be in the bottom connection of your solenoid (since your purge works) or your nitrous jet in that shark nozzle is clogged. i dont see what else it could be. Just undo those lines and check it out i guess :-? :-?
 

·
Registered
Joined
·
941 Posts
Discussion Starter #5
nah reread

"i disconnected the bottom line and nothing comes out. however, i can purge just fine."
 

·
You want to **** me?
Joined
·
4,043 Posts
ohhhh.... weird. is your purge set up like this?

or is it on the other side?
 

·
Registered
Joined
·
941 Posts
Discussion Starter #7
nah mine is bolted at the front of the intake and the purge goes through a flexible hose that goes out the middle of my cobra hood. i'll post a pic when i get her going again. it looks good but is mostly for show.
 

·
You want to **** me?
Joined
·
4,043 Posts
well i didnt mean exactly where your solenoids were lol, i just mean is it in that general order... main n20 line comes into the left of the solenoid, and the purge solenoid is on the right of it?
 

·
Registered
Joined
·
941 Posts
Discussion Starter #9
well yeah? i installed it correctly, it worked, it just doesn't work anymore because of the n2o noid.
 

·
You want to **** me?
Joined
·
4,043 Posts
this is when you take full advantage of that lifetime guaruntee :mrgreen:
 

·
Registered
Joined
·
941 Posts
Discussion Starter #11
i went to their site but NEVER received any customer assistance via email, and my phone isn't hooked up yet here. do you have info on how to ship it and what to do? it'd be nice if it had a rebuild anyways so long as they have it.
 
1 - 11 of 11 Posts
Top